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ビジュアルヘルプ – テーブル 

 

ここでは、Igor でのテーブル表示（表形式の表示）をヘルプ Table.ihf をもとに説明します。 

テーブル 

テーブルは、ウェーブの入力、修正、検査に便利です。 

また、テーブルを画像として他のプログラムにエクスポートしたり、ページレイアウトに含めることで、プレゼンテ

ーション目的にも使うことができます。 

ただし、この目的に最適化されているわけではありません。 

データポイントの数が少ない場合は、おそらくテーブルに手動で入力するのが最も便利でしょう。 

この場合、最初に新しい空のテーブルを作成します。 

データポイントの数が非常に多い場合は、Igor にファイルから読み込むことになるでしょう。 

この場合、テーブルを作成する必要はありません。 

しかし、ウェーブを検査するためにテーブルに表示したい場合もあるでしょう。 

Igor Pro のテーブルは、十分なメモリがあれば、事実上、任意の行数と列数を処理できます。 

Igor のテーブルは、他のグラフ作成プログラムのスプレッドシートと類似していますが、同一ではありません。 

主な違いは、Igor ではデータがテーブルとは独立して存在していることです。 

テーブルにデータを入力することで、Igor のメモリ内に新しいウェーブを作ることができます。 

データを入力したら、必要に応じてテーブルを削除できます。 

ウェーブはメモリ内に独立して存在するので、テーブルを削除してもウェーブは削除されません。 

ウェーブはグラフや新しいテーブルに表示することができます。 

スプレッドシートでは、あるセルを別のセルに依存させる数式を作成することができます。 

Igor では、セルベースの依存関係を作成することはできません。 

メニュー Analysis → Compose Expression、Misc → Object Status、または SetFormula コマンドを使って、

ウェーブ全体をコントロールする依存関係を作ることはできますが、日常の作業には推奨されません。 

テーブルを作るには、メニュー Windows → New Table を選択します。 

アクティブウィンドウがテーブルの場合、Igor のメニューバーに Table メニューが表示されます。 

このメニューの項目では、列の追加や削除、列の書式変更、テーブルのプレファレンスの設定が可能です。 

テーブル内のウェーブは動的に更新されます。 

ウェーブ内の値が変更されると、Igor は自動的にそのウェーブを含むすべてのテーブルを更新します。 

このため、数値計算プロシージャのトラブルシューティングには、テーブルが便利なことが多いです。 
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テーブルの作成 

新しい Experiment でのテーブルの作成 

デフォルトでは、新しい Experiment を作成すると、Igor は自動的

に新しい空のテーブルを作成します。 

通常、手動でデータを入力して作業を開始する場合に便利です。 

しかし、Igor では、データはテーブルに表示されずにメモリ内に存

在することができます。 

必要に応じて、Miscellaneous Settings ダイアログ（Misc メニュ

ー）の Experiment カテゴリを使って、テーブルの自動作成を無効

（Make a table for new experiments をオフ）にすることができ

ます。 
 

新規ウェーブを入力するための空のテーブルの作成 

メニュー Windows → New Table を選択し、Do It ボタンをクリックします。 

数値を入力すると、Igor は数値のウェーブを作成します。 

数値以外の値を入力すると、Igor はテキストのウェーブを作成しま

す。 

多次元ウェーブを作成するには、Data メニューの Make Waves 

ダイアログを使う必要があります。 

ウェーブを作成した後、名前を変更したい場合があります。 

テーブルのポップアップメニューまたはメインメニューバーの 

Data メニューから Rename を選択します。  

既存のウェーブを編集するためのテーブルの作成 

Windows メニューから New Table を選択します。 

これにより、New Table ダイアログが表示されます。 

テーブルに表示するウェーブを Columns to Edit リストから選択

します。 

Shift キーを押しながらクリックすると、複数のウェーブを選択でき

ます。 

Ctrl キーを押しながらクリックすると、個々のリスト項目を選択で

きます。 

Do It ボタンをクリックするとテーブルが作成されます。 
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インデックス値の表示 

ウェーブのヘルプで説明しているように、ウェーブにはスケールさ

れたインデックス値が組み込まれています。 

New Table と Append to Table ダイアログでは、ウェーブ内の

データのみ、またはインデックス値とデータを表示することができ

ます。 

これらのダイアログのいずれかで Edit index and data columns 

ラジオボタンをクリックすると、Igor はテーブルにインデックス列

とデータ列の両方を表示します。 

1D ウェーブの X インデックス値は、その X スケーリングによっ

て決定されます。 

これは、Change Wave Scaling ダイアログまたは SetScale コマ

ンドを使って設定するプロパティです。  

2D ウェーブには、X と Y のスケーリングがあり、X と Y のスケー 

リングされたインデックス値をコントロールします。 

高次元ウェーブには、追加のスケーリング特性とスケーリングされたインデックス値があります。 

インデックス値をテーブルに表示することは、ウェーブのスケーリングが不明な場合や、SetScale コマンドの効果

を確認したい場合に役立ちます。 

次元ラベルの表示 

次元ラベルのヘルプで説明しているように、ウェーブには次元ラベ

ルが付いています。 

New Table と Append to Table ダイアログでは、ウェーブまた

は次元のラベルとデータのみを表示することができます。 

これらのダイアログのいずれかで Edit dimension label and data 

columns ラジオボタンをクリックすると、Igor はテーブルにラベ

ルとデータ列の両方を表示します。 

次元ラベルは、個々のデータ行または列が明確な意味を持つ場合に

のみ役立ちます。 

例えば、画像では、1 つの行または列の重要性は他の行または列と

同じであるため、意味がありません。 

多次元ウェーブが、実際には関連性はあるもののばらばらのデータ  

の集合である場合は、役立ちます。 

2D ウェーブには、行の次元ラベルと列の次元ラベルがあります。

1D ウェーブには、行の次元ラベルのみがあります。 

テーブルに次元ラベルまたは次元インデックスを表示できますが、

同じウェーブに対して両方を同時に表示することはできません。 

 

水平方向のインデックス行 

多次元ウェーブがテーブルに表示される場合、Igor は列名の下、データセルの上に表示される水平方向のインデック

ス行を追加します。 

この行には、数値の次元インデックスまたはテキスト次元ラベルを表示できます。 
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デフォルトでは、ウェーブの次元ラベルの列がテーブルに表示されている場合、水平方向のインデックス行に次元ラ

ベルが表示されます。 

そうでない場合は、数値の次元インデックスが表示されます。 

このデフォルト設定は、メニュー Table → Horizontal Index を使って上書きすることができます。 

ファイルからウェーブを読み込みながらテーブルを作成 

Load Waves ダイアログ（Data メニュー）には、新たにロードさ

れたウェーブを表示するためのテーブルを作るオプションがありま

す。 

 

テーブルの部品 

下の図は、1D ウェーブを表示するテーブルの各部分を示しています。 

多次元ウェーブを表示する場合、Igor はテーブルにいくつかの追加項目を追加します。 

後半の「多次元ウェーブの編集」で説明しています。 

 

テーブルの大部分はセル領域です。 

セル領域には、数値またはテキスト形式のデータ値の列と、左側のポイント番号の列が含まれます。 

必要に応じて、インデックス列や次元ラベル列も表示できます。 

右側には未使用の列があり、ここに新しいデータを入力したり、貼り付けたりすることができます。 

テーブルが多次元ウェーブを表示している場合、名前の行の下に列インデックスまたは次元ラベルの行が含まれま

す。 

Append Columns to Table ダイアログを使って、インデックスとラベルを切り替えます。 

左上にはターゲットセル ID の領域があります。 

これは、ターゲットセルに対応するウェーブの要素を特定します。 

例えば、2D ウェーブを表示するテーブルの場合、ID 領域に「R13 C22」と表示される場合、対象のセルは 2D ウェ

ーブの 13 行目、22 列目にあることを意味します。 

3D ウェーブの場合、ターゲットセル ID にはレイヤー（「L」）が含まれ、4D ウェーブの場合、ターゲットセル ID

にはチャンク（「Ch」）が含まれます。 

ターゲットセル ID 

ターゲットセル 

廃棄ボックス 

クリックするとエン

トリが廃棄される 

承認ボックス 

クリックするとエン

トリが承認される 

入力行 

ここに数値を入力 

テーブルポップアップメニュー 

ウェーブのブラウズ、名前変

更、次元変更、削除、廃棄、ま

たは列の形式を変更する 

使われていないセル 

クリックして、数

値、非数値のテキス

トを入力すると新し

いウェーブが作成さ

れる 

列名 

クリックすると列全体が選択される 



8 

 

ターゲットセルをスクロールして表示から外れた場合、ターゲットセル ID をクリックすると、ターゲットセルをす

ばやく表示に戻すことができます。 

各データ値の列の一番下には、挿入セルと呼ばれる特別なセルがあります。 

挿入セルに値を入力するか貼り付けることで、ウェーブにポイントを追加することができます。 

 

テーブルポップアップメニューは、ウェーブの検査や変更、ウェーブの削除や破棄、1 つまたは複数の列の書式変更

を素早く行うための方法を提供します。 

テーブルポップアップメニューは、歯車アイコンをクリックするか、右クリックすることで起動できます。 

複数の列に表示されたウェーブ（複素数ウェーブおよび多次元ウェーブ）の場合、ウェーブから任意のデータ列の表

示形式を変更すると、Igor は、そのウェーブからのすべてのデータ列の形式を変更します。 

ポップアップメニューの項目には、Delay Update があります。 

通常、テーブルのセルの値を変更すると、Igor はすぐに他のテーブルやグラ

フを更新し、新しい値を反映させます。 

Delay Update を有効にすると、他のテーブルやグラフの更新が、別のウィ

ンドウをクリックするか、Delay Update を無効にするまで延期されます。 

Delay Update 更新の遅延が有効になっている場合、メニュー項目の横にチ

ェックマークが付きます。 

テーブルに入力する値のリストがあり、作業が完了するまで他のテーブルや

グラフを更新したくない場合に、この操作を行うことができます。 

Delay Update は、ウェーブからセルを削除または追加した場合は更新を遅

延させません。 

セルの値を変更した場合のみ、更新を遅延させます。 

 

テーブルの部品の表示と非表示 

Table メニューには、テーブルのさまざまな部分を表示または非表

示にする Show サブメニューがあります。 

これは、コントロールパネルでテーブルサブウィンドウを使ってデ

ータを表示するが、ユーザーにデータの入力をさせたくない場合な

ど、特殊な状況でのみ役立ちます。 

通常に使う時は、テーブルのすべての部分が表示されるように、

Show サブメニュー内のすべての項目をチェックしたままにしてお

く必要があります。 
 

入力行が非表示の場合、ユーザーはテーブル内の値を変更できません。 

 

ウェーブの最終ポイ

ントの後ろに表示さ

れる挿入セル 

挿入セルの後ろのセルは使われない 

これらはウェーブの一部ではない 
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テーブル内の矢印キーの動作 

デフォルトでは、データを入力している途中で矢印キーを押すと、

Enter キーを押して選択したセルを移動したのと同じように入力が

受け付けられます。 

一部のユーザーは、入力作業中に選択項目を入力行内で移動させる

ために矢印キーを使用することを好むと思います。 

Misc メニューの Miscellaneous Settings ダイアログの Table 

Settings カテゴリから、設定することができます。  

 

テーブルのキーボードナビゲーション 

「キーボードナビゲーション」とは、矢印キー、Home、End、Page Up、Page Down キーに対応する選択とスク

ロールの操作を指します。 

キー  動作   +Alt キー  +Ctrl キー 

左矢印  1 セル左に移動  なし   最初の列に移動 

右矢印  1 セル右に移動  なし   最後の列に移動 

上矢印  1 セル上に移動  １つ前のレイヤー  スクロールして最初の行に移動 

下矢印  1 セル下に移動  １つ後のレイヤー  スクロールして最後の行に移動 

Home  見えている最初のセルに移動 なし   スクロールして最初のセルに移動 

End  見えている最後のセルに移動 なし   スクロールして最後のセルに移動 

Page Up  １画面スクロールアップ １画面左にスクロール １画面スクロールアップ 

Page Down １画面スクロールダウン １画面右にスクロール １画面スクロールダウン 

3D または 4D ウェーブを表示しているときに、Alt+上矢印キーと Alt+下矢印キーを押すと、現在表示されているレ

イヤーが切り替わります。 

4D ウェーブを表示している場合、Ctrl+Alt+上矢印キーと Ctrl+Alt+下矢印キーで現在表示されているチャンクを変

更します。 

 

テーブル内の小数記号、桁区切り 

デフォルトでは、テーブルに数値を入力する際の小数点記号はピリ

オドです。 

これをカンマまたはシステム設定ごとに変更するには、Table → 

Table Misc メニューを使います。 

選択された小数点記号は、テーブルのデータ入力、コピー、ペース

トに使われます。 
 

小数点記号の設定は、テーブルの入力エリアで値を入力中にテンキーの小数キーを押したときに表示される文字をコ

ントロールします。 
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コンマが小数記号として選択されている場合、テーブルにテキストを貼り付けて新しいウェーブを作る時には、桁区

切りとしてサポートされません。 

Per System Setting を選択すると、小数点記号は、Igor が起動された時点でのシステム設定によって決定されま

す。 

小数点記号としてサポートされているのはピリオドとカンマのみです。 

カンマ以外の小数記号を選択した場合、ピリオドがテーブルの小数記号として使用されます。 

未使用のテーブルセルにデータを入力して新しいウェーブを作る時、まれに、Table メニューで適切な列の数値フォ

ーマットを最初に選択しないと、入力しようとしている内容を正しく解釈できない場合があります。 

例えば、小数記号がカンマで、秒以下の値を含む時間または日時を入力したい場合は、データを入力する前に、

Table → Format メニューから Time または Date and Time を選択する必要があります。 

小数点記号がピリオドの場合、3 桁ごとの区切り記号はカンマです。 

小数点記号がカンマの場合、3 桁ごとの区切り記号はピリオドとなります。 

テーブルにデータを入力するときに、3 桁ごとの区切り記号を使うことができます。 

また、桁区切りを表示する数値形式の列を選択することもできます。 

ただし、テーブルにテキストを貼り付けて新しいウェーブを作る時には、桁区切りは許可されません。 

 

テーブルを使って新しいウェーブを作る 

未使用の列をクリックすると、Igor は最初の未使用の列の最初のセルを選択します。 

値を入力するか、クリップボードにコピーしたデータを貼り付けることで、新しいウェーブを作成できます。 

値を入力して新しいウェーブを作る 

最初の未使用セルにデータ値を入力すると、Igor は 1 つの新しい 1D ウェーブを作成し、それをテーブルに表示しま

す。 

これは、少数の数字やテキスト項目を入力する時に便利です。 

数値を入力すると、日付/時刻の値も含めて、Igor は数値ウェーブを作成します。 

数値以外の値を入力すると、Igor はテキストウェーブを作成します。 

Igor は、wave0 や wave1 などのデフォルト名をウェーブに付けま

す。 

Data メニューの Rename またはテーブルポップアップメニュー

の Rename を使って、ウェーブの名前を変更できます。 

また、コマンドラインから名前を変更することもできます。 

Rename oldName, newName  

新しいウェーブを作成すると、そのウェーブにはデータポイントが 1 つ（ポイント 0）あります。 

ポイント番号 1 のセルはグレーで表示されます。 

これは挿入セルです。 

前のセルがウェーブの最後のポイントであることを示しています。 

挿入セルをクリックして値を入力したり、貼り付けを行うことができます。 

これにより、ウェーブに 1 つまたは複数のポイントが追加されます。 
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新しいウェーブが数値の場合、Miscellaneous Settings ダイアログ

の Data Loading セクションにある Default Data Precision 設定

に従って、単精度または倍精度となります。 

ただし、表示される桁数は数値フォーマットによって異なります。 

後述の「数値フォーマット」を参照してください。 

日付を入力する時には、Table メニューからアクセスできる Table 

Date Format ダイアログで選択したフォーマットを使う必要があり

ます。 

このダイアログの設定は、すべてのテーブルに影響します。 
 

日付（例：1993-01-26）、時刻（例：10:23:30）、または日付/時刻（例：1993-01-26 10:23:30）の値を入力

すると、Igor はこれを認識します。 

数値フォーマットを設定することで、値を適切に表示します。 

また、Miscellaneous Settings ダイアログの Default Data Precision 設定に関係なく、新しいウェーブを倍精度に

強制します。 

これは、単精度では日付と時刻の値を格納するのに十分な範囲がないためです。 

他のプログラムからのデータを貼り付けることで新しいウェーブを作成する 

スプレッドシートプログラムやその他のグラフ作成プログラムにデ

ータがある場合は、コピー＆ペースト機能を使って、そのデータを

Igor にインポートできます。 

他のプログラムがタブ区切りテキストまたはカンマ区切りテキスト

としてデータをクリップボードにコピーできる場合は、この方法で

動作します。 

列形式のデータを扱うほとんどのプログラムで、この操作が可能で

す。 
 

タブ区切りデータは、次のフォーマットのテキスト行が複数集まったものです。 

value <tab> value <tab> value <terminator> 

それは、列名を含む行から始まるかもしれません。 

行の終わりは、キャリッジリターン（CR）、ラインフィード（LF）、またはキャリッジリターンとラインフィード

（CR+LF）の組み合わせである<terminator>によって示されます。 

タブ区切りのテキストをワードプロセッサに貼り付けると、次のような表示になります。 

column1 column2 column3 (this line is optional) 

27.95  -13.738 12.74e3 

31.37  -12.89  13.97e3 

.  .  . 

.  .  . 

.  .  . 

もう一方のプログラムでは、対象のデータを含むセルを選択し、クリップボードにコピーします。 

Igor で、テーブル内の未使用の最初の列の最初のセルを選択し、Igor の Edit メニューから Paste を選択します。 
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Igor はクリップボードの内容をスキャンして、数値テキストデータ

の行数と列数を決定します。 

また、クリップボード内のテキストの最初の行をチェックし、列名

が含まれているかどうかを確認します。 

クリップボードまたはデフォルトの名前を使ってウェーブを作成

し、テーブルに表示します。 

テキストに既存の名前と重複する名前が含まれている場合、Igor は

問題を修正するためのダイアログを表示します。 

 

テキストのみのデータ（数値、日付、時刻、日付/時刻の値を含まない）を貼り付けた場合、Igor は最初の行を列名

として扱わず、貼り付けたテキストをすべてデータとして扱います。 

通常、これによって期待通りの結果が得られます。 

1 行目を列名として扱いたい場合は、Load Delimited Text ルーチンを使ってクリップボードからテキストを読み込

み、ウェーブ名を読み込むことを指定します。 

詳細はヘルプ Loading Delimited Text Files（Importing and Exporting Data.ihf）を参照してください。 

テーブルのコピー＆ペーストのトラブルシューティング 

ペースト時に作成されるウェーブに期待する値が含まれていない場合、クリップボードにタブ区切りのテキストが含

まれていない可能性があります。 

この場合、貼り付けを元に戻す必要があります。 

クリップボードの内容を調べるには、Igor のプレーンテキストノートブックまたは他のワードプロセッサに貼り付け

ます。 

テキストを編集した後、再度クリップボードにコピーし、テーブルにペーストし直します。 

Igor からデータを貼り付けて新しいウェーブを作成する 

また、既存のウェーブからデータをコピーして、新しいウェーブを作成することもできます。 

テーブルのウェーブデータをコピーすると、Igor は生のデータだけでなく、そのウェーブの以下のプロパティも保存

します。 

⚫ データの単位と次元の単位 

⚫ データのフルスケールと次元スケーリング 

⚫ 次元ラベル 

⚫ ウェーブのノート 

したがって、ウェーブを複製するには、テーブルにコピーし、同じテーブルまたは別のテーブルの未使用領域にペー

ストします。 

また、ある Experiment のテーブルからコピーして、別の Experiment のテーブルにペーストすることもできます。 

Igor は、ウェーブ全体をコピーした場合のみ、ウェーブのノートをコピー＆ペーストします。 

 

テーブルの名前とタイトル 

作成するテーブルはすべて名前を持ちます。 

この名前は、Igor オブジェクトの短い名前で、コマンドまたはプロシージャからテーブルを参照するために、ユーザ

ーまたは Igor が使います。 

新しいテーブルを作成すると、Igor は「Table0」、「Table1」などの形式で名前を割り当てます。 

テーブルの名前は、次項で説明するように、テーブルを削除して再作成する時に最もよく使います。 

 



13 

 

テーブルにはタイトルもあります。 

タイトルとは、テーブルウィンドウの上部に表示されるテキストで

す。 

テーブルを視覚的に識別するためのものです。 

コマンドまたはプロシージャからテーブルを識別するために使われ

ることはありません。 

タイトルは、最大 255 バイトまでの任意のテキストで構成できま

す。 
 

Window Control ダイアログを使って、テーブルの名前とタイトル

を変更することができます。 

メニュー Windows → Control → Window Control を選択して

ダイアログを表示します。 

 

テーブルの表示と非表示 

テーブルを隠すには、Shift キーを押しながらウィンドウ右上の閉じ

るボタンをクリックします。 

メニュー Windows → Tables からテーブル名を選択すると、テー

ブルを表示することができます。 

 

テーブルの Kill と再作成 

Igor では、テーブルを Kill（削除）し、後で再作成する方法を提供しています。 

後で必要になる可能性があるテーブルを一時的に削除する時に、これを使います。 

テーブルを閉じるには、テーブルウィンドウの閉じるボタンをクリックするか、または Windows メニューの 

Close を使います。 

テーブルを Kill すると、Igor はウィンドウ再作成マクロを作成する

ことを提案します。 

Igor は、現在の Experiment のプロシージャウィンドウにウィンド

ウ再作成マクロを保存します。 

ウィンドウ再作成マクロの名前はテーブルの名前と同じです。 

 

後でウィンドウ再作成マクロを呼び出して、Windows → Table 

Macros からテーブル名を選択してテーブルを再作成することがで

きます。 
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テーブルはウェーブを持つものではなく、ウェーブを表示する方法

です。 

テーブルを Kill しても、テーブルに表示されているウェーブは削除

されません。 

テーブル内のウェーブをすべて Kill したい場合は、すべてを選択

（Edit メニューの Select All）し、テーブルのポップアップメニュ

ーから Kill All Selected Waves を選択します。 

 

詳細は、ヘルプ  Closing a Window（Using Igor.ihf）および Saving a Window as a Recreation Macro（Using 

Igor.ihf）を参照してください。 

 

インデックス列 

数値ウェーブには、2 種類の数値の値が関連付けられています。保存されたデータ値と計算されたインデックス値で

す。 

例えば、実際の 1D ウェーブの各ポイントには、データ値と X インデックス値という 2 つの値があります。 

データ値はメモリに保存されます。 

X 値はポイント番号とウェーブの X スケーリングプロパティに基づいて計算されます。 

ポイント番号と X 値の対応については、ヘルプ The Waveform Model of Data（Waves.ihf）で詳しく説明してい

ます。 

ウェーブのインデックス値は計算されたものであるため、ウェーブを編集しても、

テーブルのインデックス列の値は変更されません。 

編集できるのはテーブルのデータ列の値のみです。 

ウェーブのインデックス値を変更するには、Change Wave Scaling ダイアログ

（メニュー Data → Change Wave Scaling）を使います。 

 

 

列の名前 

列の名前はウェーブ名と関連していますが、同一ではありません。 

コマンドラインまたは Igor プロシージャからテーブルの列を追加、削除、または変更するには、列の名前を使う必

要があります。 

列の名前は、ウェーブ名と、その列がウェーブのどの部分を表示するかを識別するサフィックスで構成されます。 

各実数 1D ウェーブには、2 つの列が存在できます： 

 ・ウェーブの X インデックス値または次元ラベル用 

 ・ウェーブのデータ値用 

複素数ウェーブの場合、3 つの列があります： 

 ・X インデックス値またはウェーブの次元ラベル 

 ・ウェーブの実データ値 

 ・ウェーブの虚数データ値 

もし「test」という名前の実数 1D ウェーブがある場合、そのウェーブには 3 つの列名が関連付けられています。 

test.i（「i」は「インデックス」の略）、test.l（「l」は「ラベル」の略）、test.d（「d」は「データ」の略）で

す。 

複素数 1D ウェーブに「ctest」という名前を付けた場合、そのウェーブに関連する列名は 4 つあります。 

ctest.i、ctest.l、ctest.d.real、ctest.d.imag です。 

ウェーブ名 列の名前  列の内容 

test  test.i  test のインデックス値 

test  test.l  test の次元ラベル 
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test  test.d  test のデータ値 

test  test.id  test のインデックスとデータ値 

ctest  ctest.i  ctest のインデックス値 

ctest  ctest.id  ctest のインデックスとデータ値 

ctest  ctest.d.real ctest のデータ値の実数部 

ctest  ctest.d.imag ctest のデータ値の虚数部 

多次元ウェーブの場合、「.i」と「.l」のサフィックスは同様にインデックス値または次元ラベルの単一の列を指定

し、「.d」のサフィックスはすべてのデータ列を指定します。 

テーブル関連のコマンドでは、列名を次のように省略できます。 

完全な列の仕様    省略した列の仕様 

test.d     test 

test.i, test.d    test.id 

test.l, test.d    test.ld 

ctest.d.real, ctest.d.imag   ctest.d または ctest 

ctest.i, ctest.d.real   ctest.id.real 

ctest.l, ctest.d.real   ctest.ld.real 

ctest.i, ctest.d.imag   ctest.id.imag 

ctest.l, ctest.d.imag   ctest.ld.imag 

ctest.i,ctest.d.real,ctest.d.imag  ctest.id 

ctest.l,ctest.d.real,ctest.d.imag  ctest.ld 

2D ウェーブには、X と Y のインデックス値があります。 

3D ウェーブには、X、Y、Z のインデックス値があります。 

4D ウェーブには、X、Y、Z、T のインデックス値があります。 

ただし、ウェーブの次元に関わらず、テーブルにはインデックス列が 1 つだけ存在します。 

2D ウェーブのインデックス列は、例えば、データの表示方法によっ

て、X 値または Y 値を表示します。 

インデックス列はビューによって「wave.x」または「wave.y」と

ラベル付けされます。 

Igor コマンドから列を参照する時には、特定の列名「wave.x」ま

たは「wave.y」だけでなく、一般的な列名「wave.i」も常に使うこ

とができます。 

次元ラベルの列は、テーブルに表示されている次元に関わらず、常

に「wave.l」と呼ばれます。 
 

列名を使うコマンドの例については、ヘルプ Edit（Igor Reference.ihf）を参照してください。 

 

列のアペンド（追加） 

テーブルに列を追加するには、メニュー Table → Append Columns to Table 

を選択します。 

これにより、Append Columns ダイアログが表示されます。 
 

Igor はテーブルの右端に列を追加します。 

Alt キーを押しながら列名をドラッグすると、列を新しい位置にドラッグすることができます。 
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列の削除 

テーブルから列を削除するには、メニュー Table → Remove 

Columns from Table を選択します。 

これにより、Remove Columns ダイアログが表示されます。 

 

テーブル内の列を選択し、Table ポップアップメニューを使って選

択した列を削除することもできます。 

 

 

テーブルから列を削除しても、元のウェーブは消えません。 

列はウェーブではなく、ウェーブの表示にすぎません。 

Table ポップアップメニューから Kill Waves を選択して、テーブ

ルからウェーブを削除し、ウェーブを消滅させます。 

Data メニューの Kill Waves を使って、テーブルからすでに削除し

ているウェーブを消去します。 

テーブルなど、他のダイアログで表示されているウェーブはリスト

に表示されません。 

 

セルの選択 

セルをクリックすると、そのセルがターゲットセルになります。 

以前のターゲットセルの選択が解除され、クリックしたセルがハイライト表示されます。 

新しいターゲットセルの行と列を反映してターゲットセル ID が変更され、ターゲットセルの値が入力行に表示され

ます。 

セルをクリックして対象にすると、そのセルに新しい値を入力したり、そのセルから始まるセル範囲を選択したりす

ることができます。 

選択可能な項目は次のとおりです： 

クリック    動作 

セルでクリック   1 つのセルを選択して対象セルにする 

Shift+クリック   選択範囲を拡張または縮小する 

ポイント列でクリック  行全体を選択する 

列名でクリック   列全体を選択する 

未使用の列でクリック  最初の未使用のセルを選択する 

Edit メニューで Select All を選択 すべてのセルを選択する（可能であれば） 

テーブルの選択範囲は長方形でなければなりません。 

Igor は長方形ではない範囲を選択することを許可しません。 
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Select All を選択すると、Igor は表のすべてのセルを選択しようと試みます。 

ただし、異なる長さの列がある場合は、長方形のセル配列の選択に制限されます。 

セルをクリックして対象セルとした後、マウスをドラッグすると、ドラッグしたセルが選択され、ハイライト表示さ

れます。 

セルのコピー、切り取り、ペースト、クリアを行うために、セルの範囲を選択します。 

セル ID エリアには、ドラッグ中に現在選択されている行と列の数が表示されます。 

テーブルの端を越えてドラッグすると、セル領域がスクロールし、必要なだけセルを選択できるようになります。 

ターゲットセルを移動すると、進行中のデータ入力がすべて確定されます。 

Return、Enter、Tab、または矢印キーを使って、対象となるセルを変更することができます。 

値を入力している場合は、これらのキーでも入力が確定されます。 

キー    動作（１つのセルが選択されているとき） 

Enter, 下矢印   ターゲットセルを下に移動 

Shift+Enter, 上矢印  ターゲットセルを上に移動 

Tab, 右矢印   ターゲットセルを右に移動 

Shift+Tab, 左矢印  ターゲットセルを左に移動 

セル範囲が選択されている場合、これらのキーは対象セルを選択範囲内で動きます。 

選択範囲の一方の端にある場合は、もう一方の端に移動します。 

デフォルトでは、矢印キーで対象セルを移動します。 

メニュー Table → Table Misc Settings を使って、挿入ポイント

をエントリ行に移動するように変更できます。 

テーブルで使われている列は常に連続しています。 

使われていない列をクリックすると、Igor は最初の未使用セルを選

択します。 

最初の未使用セルが選択されたときにできることは 2 つだけです。  

値を入力して新しいウェーブを作るか、クリップボードからデータ

を貼り付けて新しいウェーブを作成します。 

Igor は、最初の未使用の列の最初のセル以外の未使用のセルを選択

することを許可しません。 

 

セルの挿入 

データ値の各列の一番下には、挿入セルと呼ばれる特別なセルがあります。 

これは、ウェーブの最後のポイントのすぐ下に灰色のボックスとして表示されます。 

ウェーブに含めたいポイント数が分かっており、ウェーブに追加のポイントを挿入する必要がない場合もあります。 

しかし、テーブルに短いリストの値を入力したり、既存のウェーブに新しいデータを追加したい場合は、挿入セルに

データを入力することで実行できます。 

挿入セルに値を入力すると、Igor はウェーブを 1 ポイント分長くします。 

すると、挿入セルが 1 つ下の位置に移動し、別のポイントを挿入できるようになります。 
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挿入セルは、同時に複数のポイントでウェーブを拡張するのにも使

用できます。 

これは「値のペースト」で説明しています。 

また、Table ポップアップメニューと Data メニューの両方に表示

される Insert Points を使うか、コマンドラインで InsertPoints コ

マンドを入力して、ウェーブにポイントを挿入することもできま

す。  

値の入力 

ウェーブ上のポイントのデータ値を変更するには、その値に対応するセルをターゲットセルにし、入力行に新しい値

を入力し、入力内容を確認します。 

セルをクリックするか、ターゲットセルを移動させるキー（Enter、Tab、矢印キー）を押して入力を確定すること

もできます。 

Esc キーを押すか、X アイコンをクリックすると、入力を破棄できます。 

入力内容を確認する時にセルの範囲が選択されている場合、この範囲外のセルをクリックしない限り、対象セルは選

択セルの範囲内で移動します。 

値を入力している間、編集メニューのクリア、コピー、切り取り、ペーストの項目、それに対応するコマンドキーの

同等の操作は、入力中の行に影響を与えます。 

入力していない場合は、これらの操作はセルに影響を与えます。 

挿入セルに値を入力することは、他のセルに値を入力することとまったく同じですが、入力が確定すると、ウェーブ

が 1 ポイント分伸びます。 

インデックス値はウェーブディメンションのスケーリングに基づいて Igor によって計算されるため、インデックス

列に値を入力することはできません。 

次元ラベルは 255 バイトに制限されています。 

次元ラベルセルにペーストした場合、そのデータを 255 バイトに切り詰めます。 

Igor Pro 8.0 より前のバージョンでは、次元ラベルは 31 バイトに制限されていました。 

長い次元ラベルを使っている場合、ウェーブファイルおよび Experiment には Igor Pro 8.0 以降が必要です。 

数値入力欄に値を入力する時、入力エリアに入力した内容が有効な数値入力でない場合、Igor は確定を許可しませ

ん。 

チェックアイコンが薄暗くなり、値を入力できないことを示します。 

日付の列に値を入力するには、Table Date Format ダイアログで指定された日付形式を使う必要があります。 

テキストウェーブまたは次元ラベルを編集する時に、そのウェーブのテキストエンコーディングで有効ではないバイ

トが含まれている場合、警告が表示され、無効なバイトをエスケープコードに置き換えます。 

詳細は「無効なテキストの編集」を参照してください。 

テキストウェーブまたは次元ラベルをコントロールするテキストエンコーディングで表現できない文字を入力しよう

とすると、エラーメッセージが表示されます。 

詳細は、「特殊文字の入力」を参照してください。 

 

テーブルの表示精度 

テーブルの列に表示されるデータは、表示されるウェーブのデータタイプ、ウェーブに格納されている値、および列

に適用されている数値形式の設定によって異なります。 
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場合によっては、セル領域では完全な精度で表示されない場合がありますが、入力行では常に完全な精度で表示され

ます。 

例えば、次のテーブルは、異なる表示形式を使った 5 つの倍精度浮動小数点ウェーブを表示しています。 

それぞれのウェーブには、10、3.141592653589793、30 億という値が含まれています。 

 

最初の列は、6 桁の精度を持つ一般的なフォーマットに設定されています。 

これは、新しいテーブル列の製品出荷時のデフォルト形式です。 

一般的なフォーマットでは、表示される値に応じて、整数、浮動小数点数、または科学記法のいずれかを選択しま

す。 

列の表示フォーマットの変更は、列を右クリックし、ポップアップ

メニューから Format を選択します。 

General[1] の値は、表の本文に 3.14159 と表示されます。これ

は、フォーマットが 6 桁の精度を指定しているためです。 

このセルが対象セルとして選択されているため、その値が入力行に

表示されています。 

しかし、入力エリアでは、列のフォーマットを使うのではなく、16

桁の完全な精度で値が表示されます。 

これにより、入力エリアをクリックしてすでにそこに表示されてい

るテキストを確定した場合でも、精度が失われることはありませ

ん。 

もし General ウェーブが倍精度ではなく単精度浮動小数点であれ

ば、入力エリアには非整数の値に対して 8 桁が表示されます。 

なぜなら、単精度では 8 桁で十分なためです。 

単精度ウェーブの整数値は、最大 16 桁で表示されます。  

Integer 列は整数値として表示されるようにフォーマットされているため、3.141592653589793 は 3 と表示され

ます。 

Integer[1] をクリックすると、入力エリアには完全な精度が表示されます。 

Decimal[1] の場合も同じです。 

テーブルのセル領域は列の書式設定に従いますが、Decimal[1] をクリックすると、入力エリアには完全な精度が表

示されます。 

Hex 列と Octal 列はそれぞれ 16 進数と 8 進数表示に設定されています。 

16 進数および 8 進数のフォーマットでは小数点以下のデータの表示はサポートされていないため、Hex[1]および

Decimal[1]では値の代わりにエラーメッセージが表示されます。 

この点については、「16 進数フォーマット」と「8 進数フォーマット」のセクションでさらに詳しく説明します。 
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日付の値 

日付と時刻は、Igor の日付形式で表されます。 

1904 年 1 月 1 日午前 0 時からの経過秒数として表されます。 

それ以前の日付は負の値で表されます。 

単精度ウェーブのデータ値に日付を正確に格納することはできません。 

日付と時刻を格納する際は、必ず倍精度を使用してください。 

Igor による日付の表現方法の詳細については、ヘルプ Date/Time Waves（Waves.ihf）を参照してください。 

日付の入力方法と、Igor がテーブルに表示する方法は、メニュー Table → Table Date Format を選択して、

Table Date Format ダイアログで設定します。 

Table Date Format ダイアログで、製品出荷時のデフォルト設定で

あるシステム日付フォーマットを使うように選択すると、Region コ

ントロールパネルで設定された短い日付フォーマットを使用してテ

ーブルに日付を表示します。 

または、一般的な日付フォーマットまたはカスタムの日付フォーマ

ットを使用することもできます。 

ラジオボタン Use Common Format を選択した場合のダイアログ

は右のようになります。 

 

必要な場合には、Use Custom Format ラジオボタンをクリックす

ると、さらに柔軟に設定できます。 

区切り文字を含む一般的な日付フォーマットまたはカスタムの日付

フォーマット（例：10/05/99 または 10.05.99）を使う場合、

Igor は年号の桁数や先頭のゼロを使うことについて寛容です。 

年、月、日について、2 桁または 4 桁の年と、先頭ゼロありまたは

先頭ゼロなしを受け入れます。 
 

ただし、区切り記号のないフォーマット（例：991005 または 19991005）を使用する場合は、Igor はフォーマッ

トで指定された通りに日付を入力することを要求します。 

テーブルの最初の未使用の列に値を入力する時、Igor は入力しようとしている値の種類（数値、日付、時刻、日付/

時刻、またはテキスト）を推測する必要があります。 

次に、列のフォーマットを適切に設定し、入力された内容を適切に解釈します。 

区切り記号のない日付形式を使用すると、曖昧さが生じます。 

例えば、991005 と入力した場合、日付を入力しようとしているのか、それとも数字を入力しようとしているのか、

Igor には判断できません。 

したがって、区切り文字のない日付で構成される新しい列を作りたい場合は、値を入力する前に、メニュー Table 

→ Format から Date を選択する必要があります。 

区切り文字を含む日付については、Igor が数字と区別できるため、これは必要ありません。 

「October 11, 1999」のように、英字を含む日付形式を選択した場合は、スペースを含め、形式通りに日付を入力

する必要があります。 

Igor による日付の表現方法の詳細については、ヘルプ Date/Time Waves（Waves.ihf）を参照してください。 

 



21 

 

特別な値 

数値データ列には、2 つの特別な値を入力することができます。 

NaN と INF です。 

欠損値（NaN） 

NaN は「Not a Number」の略で、欠損値や空白データに使う値です。 

表中の NaN を空白セルとして表示します。 

NaN は、テキストデータファイル、クリップボードから貼り付けられたテキスト、Igor のコマンドラインやプロシ

ージャ内の数値表現において使うことができる正しい数値です。 

計算が意味のない結果を返した場合、例えば負の数の対数を計算した場合など、ポイントは NaN の値になります。 

表のセルに欠損値を入力するには、NaN と入力するか、入力行のテキストをすべて削除して、入力内容を確認しま

す。 

区切り記号付きのテキストデータファイルを読み込んだり、区切り記号付きのテキストを貼り付けたりする場合、間

に数値が含まれていない 2 つの区切り記号が含まれていると、ウェーブに NaN が含まれることがあります。 

無限（INF） 

INF は「無限」を意味します。 

Igor は表中の無限を「INF」と表示します。 

INF は、テキストデータファイル、クリップボードから貼り付けられたテキスト、Igor のコマンドラインやプロシー

ジャ内の数値表現において使うことができる正しい数値です。 

ゼロで割るなど、計算により無限が算出された場合、その値は INF または -INF となります。 

表のセルに INF または -INF と入力すると、無限を入力することができます。 

 

値のクリア 

クリア操作は、メニュー Edit → Clear を選択することで実行でき

ます。 

クリアは、数値列の選択されたすべてのセルをゼロに設定します。 

これは、テキストおよび次元ラベルの列で選択されたすべてのセル

を「」（空文字列）に設定します。 

インデックス列で選択されたセルには影響しません。 

数値のブロックを NaN（またはその他の数値）に設定するには、ブ

ロックを選択し、Compose Expression（Analysis メニュー）を選

択します。 

表示されたダイアログで、Wave Destination ポップアップメニュ

ーから「_table selection_」を選択します。 

式として「NaN」を入力し、Do It をクリックします。 
 

 

値のコピー 

コピー操作は、Edit → Copy を選択することで実行できます。 

これにより、選択したすべてのセルがテキストおよび Igor バイナリとしてクリップボードにコピーされます。 
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これは、あるウェーブから別のウェーブへ、あるウェーブのある部分からそのウェーブの別の部分へ、データポイン

トの範囲をコピーするのに便利です。 

また、データを他のアプリケーションや別の Experiment にエクスポートするのにも便利です（「表からのデータ

のエクスポート」を参照）。 

テーブルへのコピー＆ペーストでは、データのバイナリバージョンが使われます。 

このバージョンでは、データが完全な精度で表現され、スケーリングや単位などのウェーブプロパティも含まれま

す。 

テーブル以外の場所、例えば Igor のノートブックや他のプログラムに貼り付けた場合は、テキストバージョンのデ

ータが使われます。 

64 ビット対応に関する技術的な理由により、バイナリクリップボードのフォーマットは Igor Pro 6 のフォーマット

とは異なります。 

そのため、Igor Pro 6 からバイナリテーブルデータをコピーすることはできません。 

コピーされたデータのテキスト版では、完全な精度でデータを表現するために必要な桁数が使われます。 

テーブルに表示されている通りにテキストを正確にエクスポートしたい場合は、/F フラグを付けた Save コマン

ド、またはメニュー File → Save Table Copy（テーブルが表示されているときに表示される）、または

SaveTableCopy コマンドを使う必要があります。 

また、既存のウェーブからデータをコピーして、新しいウェーブを作ることもできます。 

「多次元のコピー/切り取り/ペースト/クリア」も参照してください。 

 

値のカット（切り取り） 

カット操作は、メニュー Edit → Cut を選択することで実行できます。 

カットは、選択したすべてのセルをテキストおよびバイナリ形式でクリップボードにコピーします。 

次に、選択したポイントをそれぞれのウェーブから削除し、ウェーブを短くします。 

インデックス値はポイント番号に基づいて計算され、保存されていないため、インデックス列のセクションをカット

することはできません。 

ただし、データまたは次元ラベルの列の一部を切り取ると、データ列に対応するインデックス列も短くなります。 

 

値のペースト（貼り付け） 

ペースト操作は、メニュー Edit → Paste を選択することで実行できます。 

ペースト操作には、置換ペースト、挿入ペースト、作成ペーストの 3 種類があります。 

ペースト形式  操作    Igor の動作 

置換ペースト  Paste を選択   選択したセルをクリップボードのデータで 

       置き換える。 

挿入ペースト  Shift を押して Paste を選択 クリップボードのデータを新しいセルとして挿入

       する。 

作成ペースト  未使用の列の最初のセルを選択し、 クリップボードデータで新しいウェーブを作成 

   次に Paste を選択   する。 

多次元ウェーブを扱う時には、他のオプションもあります。 

詳細は、「多次元のコピー/切り取り/ペースト/クリア」を参照してください。 

ペーストを行うと、Igor はまず、クリップボードにいくつの行と列の値があるかを把握することから始めます。 

クリップボードには、Igor のテーブルからコピーしたバイナリデータが含まれている場合もあれば、スプレッドシー
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トやテキストエディタなどの他のアプリケーションからコピーしたプレーンテキストデータが含まれている場合もあ

ります。 

クリップボードのデータがプレーンテキストの場合、Igor は、値の行が改行文字（CR）、ラインフィード文字

（LF）、または改行/ラインフィード（CR+LF）の組み合わせで区切られ、行内の個々の値はタブまたはカンマで区

切られていることを想定しています。 

ほとんどのアプリケーションはタブ区切りテキストとしてデータをエクスポートするので、通常は問題ありません。 

ペーストに問題があり、クリップボード内のデータの形式が不明な場合は、Igor ノートブックにペーストして確認、

編集することができます。 

Igor がクリップボード内の行と列の数を把握すると、それらの値をテーブルに、そしてテーブルが表示するウェーブ

に貼り付けます。 

未使用の列の最初のセルを選択した場合、貼り付けは新規作成ペーストになります。 

この場合、Igor は新しいウェーブを作成し、それをテーブルに追加し、クリップボードのデータを新しいウェーブに

保存します。 

クリップボード内のテキストの各行ごとに、新しいウェーブを作成します。 

テキストが列名の行から始まっている場合、Igor は新しいウェーブの名前のベースとしてこの行を使います。 

そうでない場合は、Igor はデフォルトのウェーブ名を使います。 

列数の不一致 

クリップボードの列数とテーブルで選択した列数が異なる場合、

Igor は貼り付けたい列数を尋ねてきます。 

これは、置換ペーストには適用されますが、挿入ペーストや作成ペ

ーストには適用されません。 

例えば、クリップボードに M 列のテキストがあるのに、N 列を選択

して貼り付けを行うと、Igor は Columns to Paste ダイアログを

表示し、オプションを提供します。  

⚫ Paste M columns using the current selection / 現在の選択を使って M 列をペーストする 

⚫ Change the selection and paste N columns / 選択を変更して N 列をペーストする 

行数の不一致 

クリップボード内の行数がテーブルで選択した行数と異なる場合、

Igor は貼り付ける行の数を尋ねてきます。 

これは、置換ペーストには適用されますが、挿入ペーストや作成ペ

ーストには適用されません。 

例えば、クリップボードに M 行のテキストがあるのに、N 行だけを

選択して貼り付けを行うと、Igor は Rows to Paste ダイアログを

表示し、3 つのオプションを提供します。  

⚫ Paste M rows using the current selection / 現在の選択を使って M 行をペーストする 

⚫ Change the selection and paste N rows / 選択を変更して N 行をペーストする 

⚫ Replace the selected N rows with M rows from the clipboard / 選択した N 行をクリップボードの M 行

で置き換える 

ペーストとインデックス列 

インデックス列の値はポイント数に基づいて計算されるため、貼り付けによって変更することはできません。 

しかし、選択したセルの範囲内でインデックス列とデータ列が隣接している場合は、ペーストを行うことができま
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す。 

ペーストによってデータ値は変更されますが、インデックス値は変更されません。 

ペーストと列フォーマット 

プレーンテキストデータを既存の数値列にペーストすると、Igor は列の数値フォーマットに基づいてクリップボード

内のテキストを解釈しようとします。 

例えば、列が日付形式でフォーマットされている場合、Igor はテーブルの日付形式に従ってテキストを解釈しようと

します。 

列が時間としてフォーマットされている場合、Igor はテキストを時間値（例：10:00:00）として解釈しようとしま

す。 

列が通常の数値形式の場合、Igor はテキストを通常の数値として解釈しようとします。 

未使用の列にプレーンテキストデータをペーストすると、Igor は新規作成ペーストします。 

この場合、Igor はクリップボード内のテキストを検査し、データが日付形式、時間形式、日付と時間形式、または通

常の数値形式のいずれであるかを判断します。 

テーブルに新しい列を追加する時には、適切な数値形式が適用されます。 

テーブルに 8 進数または 16 進数のテキストをペーストする時には、Igor がテキストを正しく解釈できるように、ま

ず列のフォーマットを 8 進数または 16 進数に設定する必要があります。 

列がこれらのいずれの形式にも当てはまらない場合、Igor は数値ウェーブではなくテキストウェーブを作成します。 

日付の入力方法については、「日付値」を参照してください。 

 

ウェーブのコピー＆ペースト 

Igor 内でウェーブ全体をコピー＆ペーストすることができます。 

これは、「Igor からのデータの貼り付けによる新規ウェーブの作成」で説明しています。 

 

ポイントの挿入と削除 

ペーストとカットに加えて、Data メニューまたは Table ポップア

ップメニューから Insert Points と Delete Points ダイアログを使っ

て、ウェーブにポイントを挿入したり削除したりすることもできま

す。 

これらのダイアログを使うと、テーブルを使用せずにウェーブを変

更できますが、テーブルがトップウィンドウの場合、インテリジェ

ントに動作します。 

 

 



25 

 

テーブル値の検索 

メニュー Edit → Find を選択すると、テーブル内の特定の内容を

検索できます。 

これにより、Find In Table ダイアログが表示されます。 

Find In Table 機能では、アクティブなテーブルの現在の選択範

囲、アクティブなテーブル全体、またはすべてのテーブルウィンド

ウを検索できます。 

この機能は、ダイアログの上部にある右側のポップアップメニュー

を使ってコントロールします。 

 

 

 

 

 

All Table Windows モードは、スタンドアロンテーブルウィンドウ

のみを検索します。 

テーブルサブウィンドウは検索しません。 

Top Table モードを使って、コントロールパネルでテーブルサブウ

ィンドウを検索することができます。 

Find In Table では、左側のポップアップメニューを使ってコント

ロールする次のタイプの値を検索できます。 

 

 

 

 

 

検索タイプ  説明 

Row   指定した行を表示しますが、選択はしません。 

Text String  テキスト、数値、日付、時間、日付/時間、および次元ラベルなど、あらゆる種類の列で

   指定のテキスト文字列を検索します。 

   例えば、「-1」を検索すると、-1.234 や -1e6 といった数値を含むセルが検索されま

   す。 

   検索文字列がそのセルに複数回出現していても、特定のセルは 1 回しか見つかりませ

   ん。 

   対象文字列は 254 バイトに制限されています。 

Blank Cell  テキスト、数値、日付、時刻、日付/時刻、および次元ラベルなど、あらゆる種類の列の

   空白セルを検出します。 

   数値列の空白セル（NaN）とテキスト列（ゼロ文字を含むテキスト要素）を検索しま

   す。 

Numeric Value  数値列のみで指定された範囲内の数値値を検索します。 

   テキスト、日付、時刻、日付/時刻、および次元ラベルの列は検索対象外です。 

Date   日付および日付/時刻の列のみで、指定した範囲内の日付値を検索します。 

   テキスト、数値、時刻、および次元ラベルの列は検索対象外です。 

   表の書式ダイアログ（表メニュー）で指定された書式の日付を入力できます。 

Time of Day  日付/時刻の列のみで、指定した範囲内の時間帯を見つけます。 

   テキスト、数値、日付、および次元ラベルの列は検索対象外です。 

   時刻は、00:00:00 から 24:00:00 までの時間です。 

   時刻は hh:mm:ss.ff の形式で入力し、秒と小数点以下はオプションです。 

Elapsed Time  時間列のみで、指定した範囲内の経過時間を検索します。 

   テキスト、数値、日付、日付/時刻、および次元ラベルの列は検索対象外です。 
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   時刻とは異なり、経過時間は負の値を取ることができ、24:00:00 を超えることも可能

   です。 

   時間は hh:mm:ss.ff の形式で入力され、秒と小数点以下の数字はオプションです。 

Date/Time  日付/時刻列のみで、指定した範囲内の日付/時刻を検索します。 

   テキスト、数値、日付、時刻、および次元ラベルの列は検索対象外です。 

   日付/時刻値は、日付、スペース、時刻で構成されます。 

Find In Table はポイント列を検索しません。 

検索は「アンカー」セルから開始されます。 

検索対象が最前面のテーブルまたは現在の選択範囲である場合、ア

ンカーセルはターゲットセルです。 

すべてのテーブルを検索する場合、アンカーセルは最初に開いたテ

ーブルの最初のセル、または逆方向に検索している場合は最後に開

いたテーブルの最後のセルとなります。 

Find ダイアログボックスで最初の検索を行うと、検索にはアンカー

セルが含まれます。 

Find Same を行うと、アンカーセルの次のセルから検索が開始され

ます。 

逆方向の検索を行う場合は、アンカーセルの前のセルから検索が開

始されます。  

最前面のテーブルでの検索は、ターゲットセルから開始され、

Search Backwards チェックボックスの状態に応じて前方または後

方に進みます。 

テーブルの終わりまたは始めまでくると検索が停止しますが、Wrap 

Around Seach が有効になっている場合は、テーブル全体が検索さ

れます。 

 

 

 

現在の選択範囲内での検索も、ターゲットセルから開始され、Search Backwards チェックボックスの状態に応じ

て前方または後方に進みます。 

選択範囲の終わりまたは始めまでくると検索が終了しますが、Wrap Around Search が有効になっている場合は、

選択範囲全体が検索されます。 

Search Rows First が選択されている場合、指定した列のすべての行が検索され、次に次の列のすべての行が検索さ

れます。 

Search Columns First が選択されている場合、指定された行のすべての列が検索され、次に次の行のすべての列が

検索されます。 

3D または 4D ウェーブの検索を行うには、そのウェーブだけを含むテーブルを作成する必要があります。 

その後、Table Find がウェーブ全体を検索します。 

テーブルに複数のウェーブが含まれている場合、Table Find では、テーブルに表示されていない 3D または 4D ウェ

ーブの部分（例えば、3D ウェーブの他のレイヤー）は検索されません。 

Edit メニューから Find Selection を選択すると、対象セルの書式に基づいて、文字列検索（Find Text String）、

空白セル検索（Find Blank Cells）、数値検索（Find Numeric Value）、日付検索（Find Date）、時刻検索（Find 

Time Of Day）、経過時間検索（Find Elapsed Time）、日時検索（Find Date/Time）のいずれかの検索モードが

設定されます。 

ただし、ターゲットセルが空白の場合、セルの書式に関係なく、空白セル検索（Find Blank Cells）モードが設定さ

れます。 

最初に検索を行った後、特定の内容を含む後続のセルを検索するには、Find Same（Ctrl+G）を使うと便利です。 

Ctrl+Shift+G を押すと、逆方向で再度検索を行います。 
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テーブル値の置き換え 

メニュー Edit → Replace を選択すると、テーブル内の文字列を

一括置換することができます。 

選択すると、Replace In Table ダイアログが表示されます。 

Find In Table（テーブル内検索）はすべてのテーブルを検索できま

すが、Replace In Table（テーブル内置換）は、右側のポップアッ

プメニューで設定したテーブルまたは現在の選択範囲に限定されま

す。  

Replace All をクリックすると、Replace In Table はまず、Find In Table と同じルールを使って指定されたセル

の内容を検索します。 

その後、指定された置換値で内容を置き換えます。 

次に、テーブルまたは選択範囲の終わりに到達するまで、検索と置換を続けます。 

ただし、Wrap Around Search が有効になっている場合は、テーブル全体または選択範囲全体が検索されます。 

置換を実行した直後に、Edit → Undo Replace を選択すると、す

べての置換を元に戻すことができます。 
 

Replace In Table は X 列には影響しません。 

それには、Change Wave Scaling ダイアログ（Data メニュー）を使う必要があります。 

Replace In Table では、指定された検索値を各候補セルで検索します。 

値が見つかれば、セルからテキストを抽出し、抽出したテキストに対して置換を実行します。 

セルのフォーマットに適したテキストが得られれば、置換が完了します。 

適したものがない場合、Replace In Table は停止し、エラーが発生した場所を示すエラーダイアログを表示しま

す。 

Replace In Table に関する追加の考慮事項を以下に示します。 

検索タイプ 説明 

Text String 各セルにおいて、検索文字列がすべて置換文字列に置き換えられます。 

 例えば、「22」を「33」に置き換える場合、セルに 122.223 という値が含まれていると、結果

の値は 133.333 になります。 

置換文字列は 254 バイトに制限されています。 

 文字列置換を使うと、セルの書式設定では許容されない値を生成することが可能です。 

例えば、上記の例で「22」を「9.9」に置き換えると、「19.9.9.93」となります。 

これは正しい数値ではないため、Replace In Table でエラーダイアログが表示されます。 

Date  日付列または日付/時刻列の日付を置換すること

  ができます。 

  日付/時刻列の日付を置換する場合、時刻部分は

  変更されません。 

  日付は、Table メニューの Table Date Format 

  ダイアログで指定されたフォーマットを使う必要

  があります。 

Time of Day 時刻の列または日付/時刻の列で、時刻を置き換

  えることができます。 

  日時列で時刻を置き換える場合、日付部分は変更

  されません。 
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テーブルの値を選択的に置換 

Replace In Table ダイアログは、一括置換を行うように設計されています。 

Find In Table ダイアログを使って選択的な置換を行い、その後 Find Same と Paste 操作を繰り返すことができ

ます。 

手順： 

1. Edit → Find を選択し、置換したい値を含む最初のセルを見つけます。 

2. そのセルを編集して、希望する値を入力します。 

3. そのセルの内容をクリップボードにコピーします。 

4. Ctrl+G で再度検索し、置換したい次のセルを見つけます。 

5. 見つかったセルを置き換えたい場合は、Ctrl-V で貼り付けます。 

6. 完了していない場合は、ステップ 4 に戻って繰り返します。 

 

テーブルからデータをエクスポート 

クリップボードを使って、Igor のテーブルから他のアプリケーションにデータをエクスポートすることができます。 

この方法を使う場合は、エクスポートしたデータの精度を維持するように注意する必要があります。 

Igor のテーブルからデータをコピーすると、Igor はデータをクリップボードにタブ区切りテキストと Igor バイナリ

の 2 つの形式でコピーします。 

後でそのデータを Igor のテーブルにペーストする時には、Igor のバイナリデータを使うため、コピー＆ペースト操

作を通じてすべての精度が保持されます。 

データを他のアプリケーションにペーストすると、Igor がクリップボードに保存したテキストデータが他のアプリケ

ーションで使われます。 

精度を失わないように、Igor はデータを完全な精度で表現できる桁数を使います。 

また、メニュー Data → Save Waves → Save Delimited Text 

または File → Save Table Copy  を選択して、ファイル経由でデ

ータをエクスポートすることもできます。 

 

列の位置の変更 

テーブルの列の順序を変更することができます。 

変更するには、移動したい列の名前にカーソルを移動します。 

Alt キーを押すと、カーソルが手の形に変わります。 

この状態でマウスをクリックすると、列のアウトラインを新しい位置までドラッグすることができます。 

マウスボタンを離すと、列が新しい位置に再描画されます。 

常に特定のウェーブのすべての列を一緒に保持しているため、列をドラッグすると、そのウェーブのすべての列が移

動します。 

ポイント列は移動できず、セルエリアの左端に常に表示されます。 

 

列の幅の変更 

列の幅は、列名の右にある縦の境界線をドラッグして変更できます。 
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特定のキーを押しながら操作することで、列幅の変更方法を変更することができます。 

Shift キーを押すと、ポイント列以外のすべてのテーブル列が同じ幅に変更されます。 

Ctrl キーは、多次元ウェーブのデータ列の境界をドラッグしたときに何が起こるかを決定します。 

キーが押されていない場合、ウェーブのすべてのデータ列は同じ幅に設定されます。 

キーが押されている場合、ドラッグされた列のみが変更されます。 

ダブルクリックで列の幅を自動設定 

列の右側にある縦の境界線をダブルクリックすると、列の自動サイズ調整が可能です。 

特定のキーを一緒に押すことで、列幅の変更方法を変更することができます。 

特定のキーを押していない状態で多次元ウェーブのデータ列の境界をダブルクリックすると、各データ列の幅が個別

に設定されます。 

Alt キーを押しながら多次元ウェーブのデータ列の境界をダブルクリックすると、すべてのデータ列の幅が同じに設

定されます。 

Shift キーを押すと、ポイント列以外のすべてのテーブル列が自動サイズ調整されます。 

Alt キーと一緒に Shift キーを押すと、指定されたウェーブのすべてのデータ列が同じ幅に自動サイズ調整されます。 

Ctrl キーを押すと、ダブルクリックした列のみが自動サイズ調整され、多次元ウェーブのすべてのデータ列が自動サ

イズ調整されるわけではありません。 

メニューで列の幅を自動設定 

列の幅を自動で設定にするには、列を選択し、Table メニューまた

は表の右上隅にある Table 表ポップアップメニューから Autosize 

Columns を選択します。 

また、列を右クリックしたときに表示されるコンテキストメニュー

からら Autosize Columns を選択することもできます。 

特定のキーを一緒に押すことで、列幅の変更方法を変更することが

できます。 

特定のキーを押していない状態で多次元ウェーブのデータ列が選択

された場合、そのウェーブのすべてのデータ列が個別に設定されま

す。 

 

 

 

 

 

 

 

 

 

 

Alt キーを押しながら多次元ウェーブのデータ列が選択された場合、そのウェーブのすべてのデータ列が同じ設定に

なります。 

Shift キーを押すと、ポイント列以外のすべてのテーブル列が自動サイズ調整されます。 

Alt キーと一緒に Shift キーを押すと、指定されたウェーブのすべてのデータ列が同じ幅に自動サイズ調整されます。 

Ctrl キーを押すと、選択した列のみが自動調整され、多次元ウェーブの他のデータ列には自動サイズは適用されませ

ん。 

列の幅の自動設定の制限 

列の自動サイズ調整を行う場合、その列内のすべてのセルの幅を決定する必要があります。 

非常に長い列（100,000 ポイント以上）の場合、長い時間がかかる場合があります。 

このような場合、セルのチェックは停止し、自動サイズ調整はチェックされたセルのみに基づいて行われます。 
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同様に、列数が非常に多い多次元ウェーブ（10,000 以上の列）のデータ列を自動サイズ調整した場合、長い時間が

かかる可能性があります。 

このような場合、列のチェックが停止し、自動サイズ調整はチェックされた列のみに基づいて行われます。 

既定の時間制限が適切でない場合は、ModifyTable コマンドの autosize キーワードを使用して時間制限を設定しま

す。 

 

列のスタイルの変更 

テーブルの列の表示スタイルは、Modify Columns ダイアログ（メ

ニューTable → Modify Columns）、メインメニューバーの Table

メニュー、テーブルのポップアップメニュー、または右クリックで

表示されるコンテキストメニューを使って変更できます。 

Modify Columns ダイアログは、Table メニュー、テーブルのポッ

プアップメニュー（歯車アイコン）、コンテキストメニュー、また

は列名をダブルクリックすることで起動できます。 

Columns to Modify リストで、1 つまたは複数の列を選択できま

す。 

複数の列を選択した場合、ダイアログ内の項目には、最初に選択し

た列の設定が反映されます。 

選択が完了すると、選択した列の設定を変更することができます。 

この操作を終えたら、別の列または列のセットを選択して、さらに

変更を加えることができます。 
 

Igor はそれまでに加えた変更をすべて記憶しているので、ダイアロ

グを 1 回開くだけですべてを行うことができます。 

ダイアログを使わずに、すべての列の設定を一度に変更するショー

トカットがあります。Table メニュー、テーブルポップアップメニ

ュー、またはコンテキストメニューから項目を選択する時に、Shift

キーを押します。 

テーブルは主に、画面上のデータ編集を目的としています。 

テーブルを画像として他のプログラムにエクスポートしたり、ペー

ジレイアウトに含めることで、プレゼンテーション目的でテーブル

を使うことができます。  

しかし、これはこの目的には理想的ではありません。 

例えば、背景色やグリッド線の外観を変更する方法がないためです。 

お気に入りのスタイルをプレファレンスとして保存できます。 

「テーブルのプレファレンス」を参照してください。 
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列プロパティの変更 

1D ウェーブのインデックスまたは次元のラベル列とデータ列に対し

て、色、列幅、フォントなどのプロパティを個別に設定することが

できます。 

特殊なケースを除いて、多次元ウェーブのデータ列はすべて同じプ

ロパティを持つべきです。 

Table メニューまたは Modify Column ダイアログを使って多次元

ウェーブの 1 つのデータ列のプロパティを設定すると、すべてのデ

ータ列のプロパティを同じように設定されます。 

例えば、3 x 3 の 2D ウェーブを編集している時に、最初のデータ

列を赤に設定すると、は 2 番目と 3 番目のデータ列も赤になりま

す。 

 

Igor は、多次元ウェーブのデータ列をすべて同じに設定する傾向が

ありますが、異なる設定も可能です。 

変更する列を選択します。Ctrl キーを押しながら Table メニューま

たは Table ポップアップメニューをクリックし、選択します。 

選択した内容は、選択したウェーブのすべてのデータ列ではなく、

選択した列のみに適用されます。 

 

ModifyTable コマンドでは、テーブル内の位置によって列を指定する列番号の構文がサポートされています。 

このコマンドを使うと、任意の列を任意の設定にすることができます。 

コマンドで指定する場合は次のようになります： 

Make/O/N=(3,3) mat 

Edit mat 

ModifyTable rgb[1]=(50000,0,0), rgb[2]=(0,50000,0) 

これは mat の最初のデータ列を赤、2 番目の列を青に設定します。 

 

 

列番号の構文を使って、列の範囲を指定することができます。 

Make/O/N=(3,3) mat 

Edit mat 

ModifyTable rgb[1,3]=(50000,0,0) 

 

Modify Columns ダイアログでは、複素数ウェーブの実数部と虚数部の両方の列のプロパティを同時に設定します。 

もし本当に実数列と虚数列のプロパティを別々に設定したい場合は、上記の列番号構文を使用する必要があります。 

列タイトル 

列タイトルは各列の一番上に表示されます。 

デフォルトでは、Igor は自動的に列に表示されているウェーブの名前から列タイトルを作成します。 

例えば、wave0 の X インデックスとデータ値、および wave1 のデータ値を表示すると、表には wave0.x、

wave0.d、wave1 というタイトルの列が作成されます。 
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メニュー Windows → New Table を選択し、wave0 を選択する

ときに Edit index and data columns を選択します。 

次に Table メニューから Append Columns to Table を選択して、

Edit data columns only を選択すると、右のようになります。 

 

Igor は、列を区別する必要がある場合にのみ、「.x」と「.d」というサフィックスを使います。 

インデックス列が表示されていない場合は、Igor はサフィックスを省略します。 

Modify Columns ダイアログのタイトル設定を使うと、自動的に割り当てられたタイトルを独自のタイトルに置き換

えることができます。 

タイトル設定からすべてのテキストを削除すると、自動タイトルが再び有効になります。 

タイトル設定は、このテーブル内の列のタイトルのみを変更します。ウェーブ名は変更されません。 

主に、プレゼンテーション（レイアウトやエクスポートした画像）でテーブルの見栄えを良くするために、列タイト

ルの設定を実装しています。 

プレゼンテーションにテーブルを使っていない場合は、Igor に列タイトルを自動的に生成させる方が混乱の可能性が

低くなります。 

ウェーブの名前を変更する場合は、データおよびテーブルのポップアップメニューにある Rename を使ってくださ

い。 

多次元ウェーブで列タイトルをどうしても使う必要がある場合は、「列プロパティの変更」で説明しているテクニッ

クを使用して、個々の列のタイトルを設定してください。 

数値フォーマット 

テーブルの列には、テキストまたは数値ウェーブが表示されます。 

数値ウェーブの場合、列のフォーマットによって、ウェーブ内のデータ値の入力と表示方法が決まります。 

テキストウェーブのデータ列には、列形式は影響しません。 

通常の数値フォーマットに加え、テーブルでは日付、時間、日付/時

刻フォーマットもサポートしています。 

フォーマットは、単に数値を表示する方法にすぎません。 

日付や時刻も、Igor では内部的に数値として保存されます。 

テーブルの数値列に値を入力する時には、列のフォーマットを適切

に設定すれば、数値、日付、時刻、日付/時刻として入力することが

できます。 
 

以下の表は、すべての数値フォーマットを一覧表示しています。 

数値フォーマット  説明 

General  数値を、その数値自体に適した形式で表示します。 

非常に大きな数値や小さな数値は、科学記法で表示されます。 

その他の数値は小数形式で表示されます（例：1234.567）。 

桁数設定では有効数字の桁数をコントロールします。 

整数には小数桁は表示されません。 

Integer   数値は、最も近い整数として表示されます。 

   例えば、1234.567 は 1235 と表示されます。 

Integer with comma 数字は、最も近い整数値として表示されます。 

 さらに、3 桁ごとの数字のグループを区切るためにカンマが使用されます。 

例えば、1234.567 は 1,235 と表示されます。 
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Decimal  小数点の左側の桁数が、必要な数だけ表示されます。 

小数点以下の桁数をコントロールする設定は、Digits です。 

例えば、桁数が 2 桁と指定されている場合、1234.567 は 1234.57 と表示されます。 

Decimal with comma 小数点以下の桁数が 3 桁ごとにカンマで区切られていることを除いて、10 進数表記と同

じです。 

Scientific  数値は科学記法で表示されます。 

   小数点以下の桁数をコントロールする設定は、Digits です。 

Date  日付は、Table Date Format ダイアログで設定された書式で表示されます。 

「日付/時刻の書式」を参照してください。 

Time   [+][-]hhhh:mm:ss[.ff] [AM/PM]。 

   「日付/時刻の書式」を参照してください。 

Date & Time  日付形式＋スペース＋時刻形式です。 

   「日付/時刻の書式」を参照してください。 

Octal  数値は 8 進数（基数 8）表記で表示されます。 

サポートされるのは整数のみです。 

表示される桁数は、ウェーブデータの種類によって決まり、桁数設定は無視されます。 

詳細は「8 進数フォーマット」を参照してください。 

Hexadecimal  数値は 16 進数（16 進表記）で表示されます。 

サポートされるのは整数のみです。 

表示される桁数は、ウェーブデータの種類によって決まり、桁数設定は無視されます。 

詳細は「16 進数フォーマット」を参照してください。 

テーブルに数値を入力する時、小数点記号としてドットまたはカン

マを使う必要があります。 

これは、Table Misc Settings ダイアログの Decimal Symbol で

設定されます。 

出荷時のデフォルト設定はドットです。 

この設定は、テーブルへの数値入力のみに適用されます。 

 

変更するには、メニュー Table → Table Misc Settings を選択します。 

システム設定ごとに設定されている場合、システム小数点記号を変更すると、変更を有効にするには Igor を再起動

する必要があります。 

ほとんどの数値フォーマットでは、表示する桁数をコントロールす

ることができます。 

Modify Columns ダイアログ、または Table メニューの数字サブメ

ニュー、テーブルのポップアップメニュー（歯車アイコン）、テー

ブルのコンテキストメニューを使用して設定できます。 

Digits サブメニューから選択する数字の意味は、数値のフォーマッ

トによって異なります。 

 

数値フォーマット   指定する項目 

General    表示桁数 

Decimal (0.0...0)   小数点以下の桁数 

Decimal with comma (0.0...0) 小数点以下の桁数 

Time and Date&Time  秒以下の端数を表示する時の小数点以下の桁数 
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Scientific (0.0...0E+00)  小数点以下の桁数 

整数値、8 進数、16 進数を使って表示される列には、Digits 設定は影響しません。 

また、テキストウェーブを表示する列にも影響しません。 

小数点以下の秒の表示が有効になっている場合のみ、日付/時刻形式に影響します。 

General フォーマットでは、末尾のゼロを表示するかしないかを選択できます。 

Igor は、-9999:59:59 から+9999:59:59 までの時間形式を受け入れ、表示します。 

これは経過時間のサポートされている範囲です。 

経過時間ではなく、ある時間帯を入力する場合は、00:00:00 から 23:59:59 の範囲に制限する必要があります。 

時刻および日付/時刻形式では、小数点以下の秒数を表示するかどう

かを選択できます。 

時間データを取り扱うほとんどの人は、秒の数値として整数を使っ

ています。 

したがって、デフォルトでは、テーブルは小数秒を表示しません。 

テーブルで小数秒を表示したい場合は、メニュー Table → 

Format から Show Fractional Seconds を選択して設定する必要

があります。 

この設定を行うと、メニュー Table → Digits で、分数部分に表示

される桁数をコントロールできるようになります。  

常に小数秒まで表示したい場合は、Capture Table Prefs ダイアログを使って、Show Fractional Seconds 設定が

オンの列をキャプチャします。 

これは、プレファレンスをキャプチャした後に作成されたテーブルに適用されます。 

秒以下の小数を表示する場合、Igor は常に末尾のゼロを表示し、メニュー Table → Format の Show Trailing 

Zeros メニュー項目は影響を与えません。 

フォーマットを選択する時には、単精度浮動小数点データは約 7 桁の小数、倍精度浮動小数点データは約 16 桁の小

数を格納することを覚えておいてください。 

小数点以下までデータを検査したい場合は、十分な桁数を持つフォーマットを選択する必要があります。 

テーブルから他のアプリケーションにクリップボード経由でエクスポートするデータの精度は、フォーマットには影

響されません。 

「テーブルからのデータのエクスポート」を参照してください。 

日付/時刻フォーマット 

「日付値」のセクションで説明しているように、テーブルへの日付の入力方法と表示方法は、Table メニューから呼

び出す Table Date Format ダイアログによってコントロールされます。 

このダイアログでは、すべてのテーブルの日付形式を決定するグローバルなプレファレンスを設定します。 

列のフォーマットを時間形式に設定すると、Igor は経過時間形式で時間を表示します。 

入力できる経過時間は、-9999:59:59 から+9999:59:59 までです。 

経過時間にマイナス記号を付けることで、マイナスの経過時間を入力することができます。 

また、例えば 31:35:20.19 のように、秒単位の数値を入力することもできます。 

小数点以下の秒数を表示するには、Table メニューの Format サブメニューから Show Fractional Seconds を選択

します。 

また、時刻を時間帯形式で入力することもできます。 

例えば、1:45 PM、1:45:00 PM、13:45、13:45:00 などです。 

AM または PM の前にスペースを入れることは可能ですが、必須ではありません。 

AM と am は、表示される時刻に影響を与えません。 
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Igor は、時間帯の時間または経過時間に関わらず、同じ方法で時間を保存します。 

違いは、値をどのように考えるか、またグラフに表示する方法を選択するかです。 

以下は、有効な時間帯の例です。 

00:00:00 (midnight)  12:00:00 (noon) 

 06:30:00 (breakfast time) 18:30:00 (dinner time) 

 06:30 (breakfast time)  18:30 (dinner time) 

 06:30 PM (dinner time)  18:30 PM (dinner time) 

以下は有効な経過時間です。 

 -00:00:10 (T マイナス 10、そしてカウント中) 

 72:00:00 (3 日間の経過時間) 

 4:17:33.25 (小数点以下の秒数を含む経過時間) 

テーブル内の日付/時刻のウェーブのフォーマットは、ウェーブの内容に応じて、デフォルトで「日付」、「時

刻」、または「日付/時刻」となります。 

日付/時刻データをグラフに表示する方法については、ヘルプ Dat/Time Axes（Graphs.ihf）を参照してください。 

8 進数フォーマット 

テーブル内の数値列をすべて 8 進数形式にフォーマットすることができます。 

8 進数形式で表示されている列の数値設定は無視され、常にサポートされている値の範囲に必要なすべての数字を表

示します。 

浮動小数点ウェーブ（単精度および倍精度）では、正確なウェーブ

値を表示するためにマイナス記号を使用して負の値を表示します。 

例えば、-1 は-00000001 と表示されます。 

浮動小数点ウェーブには、値が小数であるか、またはサポートされ

ている値の範囲を超えるため 8 進数では表示できない値を格納する

ことができます。  

このような場合、テーブルには「# Can't format fractional value as octal（# 小数部を 8 進数でフォーマットで

きません）」や「# Value too large to display as octal （# 8 進数で表示するには値が大きすぎます）」などのエ

ラーメッセージが表示されます。 

浮動小数点ウェーブを、あるサイズの整数データとして使っている場合は、Redimension コマンドを使って、ウェ

ーブを適切な整数型に次元を変更することを検討してください。 

例えば、16 ビット符号付き整数データを浮動小数点ウェーブに保存している場合、テーブルでより適切な 8 進表示

を得るために、ウェーブを 16 ビット符号付き整数として再構成することを検討してください。 

16 進数フォーマット 

テーブル内の数値列をすべて 16 進数でフォーマットすることができます。 

Igor は、16 進数で表示されている列の数値設定を無視し、サポートされている値の範囲に必要なすべての数字を常

に表示します。 

浮動小数点ウェーブ（単精度および倍精度）では、ウェーブ値を正

確に表示するために、負の値はマイナス記号を使って表示されま

す。 

例えば、-1 は-00000001 と表示されます。 

小数点以下がある、またはサポートされている数値の範囲を超える

ため、16 進数では表示できない値を浮動小数点ウェーブに格納する

ことが可能です。 
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このような場合、テーブルには「# Can't display fractional value as hex（# 小数点以下の値を 16 進数で表示で

きません）」や「"# Value too large to display as hex（# 値が大きすぎて 16 進数で表示できません）」などの

エラーメッセージが表示されます。 

浮動小数点ウェーブを、あるサイズの整数データとして使っている場合は、Redimension コマンドを使って、ウェ

ーブを適切な整数型に次元を変更することを検討してください。 

例えば、16 ビット符号付き整数データを浮動小数点ウェーブに保存している場合、テーブルでより適切な 16 進表示

を得るために、ウェーブを 16 ビット符号付き整数として再構成することを検討してください。 

オブジェクト参照ウェーブのフォーマット 

このセクションは、上級者の方を対象としています。 

テキストおよび数値のウェーブに加え、テーブルにはオブジェクト参照ウェーブも表示できます。 

オブジェクト参照ウェーブは、WAVE ウェーブまたは DFREF ウェーブです。 

オブジェクト参照ウェーブの要素は、10 進整数、16 進数、8 進数のいずれかで、完全な精度で表示されます。 

列のフォーマットが整数または 8 進数である場合、列は整数または 8 進数として表示されます。 

列のフォーマットが一般、小数、科学記法、日付、時間、日付と時間など、その他のフォーマットの場合、列は 16

進数で表示されます。 

 

テキストウェーブの編集 

テーブルの最初の未使用セルをクリックし、数字以外のテキストを入力すると、テーブル内にテキストウェーブを作

成できます。 

テキストウェーブの編集は、ほとんどの場合、自明です。 

しかし、特殊文字や大量のテキストに関連する問題など、いくつかの問題に直面する可能性があります。 

1 つのセルに大量のテキスト 

テキストウェーブは、数値ウェーブの対応するデータに短い説明を保存するのに便利です。 

場合によっては、大量のテキストを保存することが便利なこともあります。 

Igor では、テキストウェーブのポイントの文字数に制限はありません。 

しかし、テーブルの入力エリアは 100,000 バイト以上を処理できません。 

100,000 バイト以上のデータを含むセルをクリックすると、Igor がそのセルはテーブルでは編集できないことを知

らせます。 

Edit Text Cell ダイアログ 

数値ウェーブデータの編集にはテーブルの入力行を使います。 

テキストウェーブデータの編集には、テーブルの入力行またはテキストセルの編集ダイアログを使います。 

複数行のデータを編集する時に便利なダイアログです。 

注釈に使うテキストを編集する時にも便利です。 

テキストウェーブセルが選択されると、テーブルのエントリ行の右端にアイコンが表示されます。 

このアイコンをクリックすると、ダイアログが表示されます。 

タブ、ターミネーター、その他のコントロール文字 

まれに、タブやターミネーター（キャリッジリターン[CR]やラインフィード[LF]）などの制御文字を含むテキストを

テキストウェーブに保存したい場合があります。 
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テーブルの入力行にはこのような文字を入力できませんが、Edit Text Cell ダイアログを使って入力することはでき

ます。 

ダイアログを表示するには、表のエントリ行の右端にあるアイコン

をクリックします。 

このアイコンは、既存のテキストウェーブを編集している場合にの

み表示されます。 
 

Edit Text Cell ダイアログで、テキスト入力エリアを右クリックし

て Settings → Show Whitespace を選択すると、空白文字（タ

ブ、スペース、終端文字）を表示することができます。 

これは複数行のテキストを編集する時に便利です。 

タブと終端記号は、これらの記号で識別されます。 

→  タブ 

↵  キャリッジリターン（CR） 

  歴史的な理由により、CR が Igor の標準の改行コ

  ードです。 
 

 Igor で使うテキストは、CR で改行する必要があります。 

¬  ラインフィード（LF） 

  LF は Unix 標準の改行コードです。 

  Unix プログラムで使うテキストは、LF 改行コードを使うべきです。 

¶ キャリッジリターン/ラインフィード（CRLF） 

CRLF は Windows 標準の改行コードです。 

Windows プログラムで使うテキストには、CRLF の改行コードが必要です。 

ダイアログのテキスト入力エリアに 1 つ以上の終端記号が含まれている場合、終端記号を変更できるボタンが表示さ

れます。 

コマンドを実行することで、コントロール文字を入力することもできます。 

例えば 

textWave0[0] = "Hello¥tGoodbye"  // タブ文字を持つテキスト 

タブには「\t」、キャリッジリターンには「\r」、ラインフィードには「\n」を使います。 

コマンドラインからテキストウェーブを出力すると、それがどのようなものか確認できます。 

Print textWave0 

これは、エスケープシーケンスを使ってタブ、改行、およびラインフィードを表示します。 

エキスパートのユーザーには、デバッグ目的で、Ctrl キーを押しながらセルをダブルクリックすると、テキストウェ

ーブと次元ラベルセルの内容の 16 進ダンプを取得できます。 

コマンドウィンドウの履歴領域に、16 進ダンプが出力されます。 

 

無効なテキストの編集 

テキストエンコーディングによっては、一部のバイトパターンが無効となります。 

例えば、次のコマンドは、無効なテキストを含む UTF-8 テキストウェーブを作成します。 
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Make/O/T test = {"A", "¥xFE", "C"} 

// "¥xFE"は、値 0xFE の 1 バイトを表す 

UTF-8 では、0x00～0x7F の範囲外のバイトは、マルチバイト文字

の一部でなければならないため、ウェーブのポイント 1 は無効で

す。 

無効なバイトは、Unicode の置換文字を使ってテーブルのセルに表

示されます。 
 

このような状況が発生する可能性が最も高いのは、MacRoman、

Windows-1252、または Shift JIS のテキストを含むテキストウェ

ーブがあるにもかかわらず、ウェーブのテキストエンコーディング

が誤って UTF-8 に設定されている場合です。 

この場合、無効なテキストを削除するためにウェーブを編集する

か、またはメニュー Misc → Text Encodings → Set Wave Text 

Encoding を使って、Igor が認識したウェーブのテキストエンコー

ドを修正することができます。 

無効なテキストを含むセルをクリックすると、黄色の警告アイコン

を表示します。 

セルの内容を編集しようとすると、警告ダイアログを表示します。  

黄色の警告アイコンが表示されている場合、入力行は特別なモード

で動作します。 

セル内の無効なバイトは、それぞれエスケープコード「x」で表され

ます。 

上記の例で、ウェーブのポイント 1 を表すセルをクリックすると、

Igor はエントリーエリアに「xFE」と表示します。  

テキストを編集する時には、ほとんどの場合、エスケープシーケンスを削除したいと思うでしょう。 

入力エリアのテキストを確定すると、Igor は残りのすべてのエスケープシーケンスを、それらが表すバイトに変換し

ます。 

上記の例では、編集プロセスを開始し、入力行に変更を加えず、テキストを受け入れたと仮定すると、編集後もセル

の内容は編集前と同じになります。 

テーブルでのエスケープシーケンスの使用は、黄色の警告アイコンが表示されている場合のみ適用されます。 

これは、セルを選択した時に、そのセルに無効なテキストが含まれていたことを示しています。 

これは、エスケープシーケンスの「x」のみに適用され、\t（タブ）、\r（キャリッジリターン）、\n（ラインフィ

ード）などの他のエスケープシーケンスには適用されません。 

黄色の警告アイコンが見えない場合、エスケープシーケンスに特別な処理はありません。 

エキスパートユーザーのためのデバッグを目的として、黄色の警告アイコンをダブルクリックすると、テキストウェ

ーブと次元ラベルセルの内容の 16 進ダンプを取得できます。 

警告アイコンが表示されているかどうかに関わらず、Ctrl キーを押しながらセルをダブルクリックすると、16 進ダ

ンプを取得できます。 

16 進ダンプは、コマンドウィンドウの履歴領域に表示されます。 

ヘルプ Text Encodings（Text Encodings.ihf）、Wave Text Encodings（Text Encodings.ihf）を参照してくださ

い。 
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制御文字の編集 

制御文字の ASCII コードは 16 進数で表され、0x00 から 0x1F の範囲に含まれますが、0x7F は削除制御文字で

す。 

タブ（0x09）、キャリッジリターン（CR、0x0D）、ラインフィード（LF、0x0A）以外の制御文字はほとんど使わ

れることがありません。 

それらが表示される場合は、エラーやバグが原因であることが多いです。 

Null（0x00）は、文字列の終端を意味するものとして多くのプログラムで内部的に使われていますが、テキスト文書

には表示されるべきではありません。 

ほとんどのコンピュータフォントでは、制御文字は空白として表示されます。 

そのため、意図的であるか、誤りであるかを問わず、テキスト中にそれらが現れた場合、それらを認識し編集するこ

とが困難になります。 

Igor がテーブルセルに制御文字を表示する場合、「代用」シンボルを表示して、空白ではなくそこに何があるかを確

認できるようにします。 

以下に例をいくつか挙げます。 

制御文字  ASCII コード 代用シンボル（Unicode） 

Tab  0x09  → (U+2192) 

CR  0x0D  ↵ (U+21B5) 

LF  0x0A  ¬ (U+00AC) 

CRLF  0x0D, 0x0A ¶ (U+00B6) 

Null  0x00  ␀ (U+2400) 

Escape  0x1B  ␛ (U+241B) 

制御文字を含むセルをクリックすると、黄色の警告アイコンが表示されます。 

セルの内容を編集しようとすると、警告ダイアログが表示されます。 

黄色の警告アイコンが表示されている場合、入力行は特別なモードで動作します。 

入力行のテキストを編集して確定すると、残りの代用シンボルを、それらが表す制御文字に戻します。 

テーブルにおける代用シンボルの使用は、黄色の警告アイコンが表

示されている場合のみに適用されます。 

黄色の警告アイコンが表示されていない場合は、これらのシンボル

に特別な処理は行われません。 

Miscellaneous Settings ダイアログの Table セクションにある 

Use Special Symbols for Control Characters チェックボックスの

チェックを外すことで、代用シンボルの使用を無効にすることがで

きます。 

まれなケースを除いて、この設定はチェックしたままにしておくべ

きです。  
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特殊文字の入力 

セルを編集している時に、ギリシャ文字や数学記号などの特殊文字

を入力するには、メニュー Edit → Characters を選択して、ギリ

シャ文字や数学記号などの一般的に使用される文字を入力するか、

メニュー Edit → Special Characters を選択してその他の文字を

入力します。 

編集している要素のウェーブが UTF-8 テキストエンコーディングを

使っている場合、それは Igor 7 以降で作成されたウェーブのデフォ

ルトです。 

任意の文字を入力できます。  

ウェーブが別のテキストエンコーディングを使っている場合、すべ

ての文字を表示することはできません。 

例えば、トリプルインテグラル文字 ∭（U + 222D）は、

MacRoman、Windows-1252、Shift JIS、またはその他の非ユニ

コードテキストエンコーディングでは表現できません。 

ウェーブのテキストエンコーディングで表現できない文字を入力し

ようとすると、問題を知らせる警告を表示します。 

その文字を省略するか、またはメニュー Misc → Text Encoding 

→ Set Wave Text Encoding を使って、ウェーブを UTF-8 に変換

するかのいずれかを選択できます。 

  

ヘルプ Text Encodings（Text Encodings.ihf）、Wave Text Encodings（Text Encodings.ihf）を参照してくださ

い。 

 

多次元ウェーブの編集 

多次元ウェーブをテーブルで表示する場合、1D ウェーブでは存在しない項目をテーブルに追加します。 

これを確認するには、2D ウェーブを作成して表示する次のコマンドを実行します。 

Make/O/N=(3,4) w2D = p + 10*q; Edit w2D.id 

テーブルの最初の列には Row というラベルが付けられており、行

番号を表示していることを示しています。 

2 番目の列には、縮小された行インデックスが含まれています。こ

の場合、行番号と同じです。 

残りの列には、ウェーブデータが表示されます。 
 

ウェーブデータの最初の列の一番上の名前に注目してください：w2D[][0].d。 

w2D がウェーブを示します。 

.d は、その列がウェーブインデックスではなく、ウェーブデータを表示することを意味します。 

[][0] は、この列で示されるウェーブの部分を示しています。 

[] は「すべての行」を意味し、[0] は「列 0」を意味します。 
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次のコマンドは、ウェーブの列 0 のすべての行に値を格納するため

に使う構文から派生したものです。 

w2D[][0] = 123 // 列 0 のすべての行を 123 に設定 

多次元ウェーブをテーブルに表示する場合、名前の行の下のテーブ

ルに行を追加します。 

この行は水平インデックス行と呼ばれます。  

この行には、下の列に表示されるウェーブ要素のスケールインデックスまたは次元ラベルのいずれかを表示できま

す。 

デフォルトでは、テーブルで 2D ウェーブを表示し、ウェーブのインデックス列を追加すると、ウェーブデータの左

側にウェーブの行インデックスを列で表示し、ウェーブデータの上に水平インデックス行でウェーブの列インデック

スを表示します。 

ウェーブの次元ラベル列を追加すると、ウェーブの行ラベルをウェーブデータの左側の列に表示し、ウェーブの列ラ

ベルをウェーブデータの上の水平インデックス行に表示します。 

インデックス列も次元ラベルも表示しない場合でも、水平インデッ

クス行にウェーブの列インデックスを表示します。 

数値インデックスを水平に、次元ラベルを垂直に、またはその逆に

表示したい場合は、メニュー Table → Horizontal Index を使っ

て、デフォルトの動作を上書きすることができます。 

例えば、次元ラベルを縦に、数値インデックスを横に配置したい場

合は、ウェーブの次元ラベルの列をテーブルに追加し、次にメニュ

ー Table → Horizontal Index → Numeric Indices を選択しま

す。 

 

上記の例では、行と列のインデックスは、行と列の要素番号と等しくなります。 

2D データの行と列のスケーリングを設定して、データの性質を反映させることができます。 

例えば、データが縦横ともに解像度 5mm の画像である場合、次のコマンドを使って Igor にそれを伝える必要があ

ります。 

SetScale/P x 0, .005, w2D; SetScale/P y 0, .005, w2D 

そうすると、テーブル内の行と列のインデックスが、指定したスケーリングを反映していることがわかるでしょう。 

1D ウェーブには列インデックスがありません。 

したがって、テーブルに多次元ウェーブがない場合、Igor は水平インデックス行を表示しません。 

テーブルに 1D ウェーブと多次元ウェーブが混在している場合、Igor は水平インデックス行を表示しますが、1D ウ

ェーブについてはその行に何も表示しません。 

1D データを表示すると、テーブルの左側にポイント番号の列が表示

されます。 

これをポイント列と呼びます。 

2D ウェーブを表示する時、2D ウェーブの表示方法に応じて、列の

タイトルを「Row」または「Column」とします。 

テーブルに 3D または 4D のウェーブがある場合、ウェーブの表示

方法に応じて、列のタイトルを「Row」、「Column」、

「Layer」、「Chunk」とします。  

1 次元ウェーブと多次元ウェーブを混ぜて表示することは可能ですが、これらのタイトルはどれも適切ではありませ

ん。 
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例えば、2 つの 2D ウェーブを表示し、1 つはウェーブ行を縦に表示

し（通常のケース）、もう 1 つはウェーブ行を横に表示することが

できます。 

この場合、Igor は「Point」列に「Element」というタイトルを付

けます。 

wave1 の列をクリックし、2D ウェーブを２つ表示し、右上のアイ

コンをクリックします。 

 

Choose Dimensions ダイアログで、”Columns” vertically in 

table、”Rows” horizontally in table と設定します。 

 

右図のように wave1 の行が水平方向に表示されます。 

 

テーブルのセルをクリックして入力するだけで、テーブルの本体で次元ラベルを編集することができます。 

ただし、この方法では、横インデックス行の次元ラベルを編集することはできません。 

そのかわり、この行のラベルをダブルクリックする必要があります。 

次に、次元ラベルを入力できるダイアログが表示されます。 

コマンドラインから SetDimLabel コマンドを使って、次元ラベルを設定することもできます。 

データの表示の変更 

テーブルは、次元 1 から 4 までのウェーブを表示できます。 

1 次元のウェーブは単純な数値の列として表示され、ウェーブが複素数の場合は、実数と虚数の 2 つの列として表示

されます。 

2 次元ウェーブは行列として表示されます。 

1 次元および 2 次元の場合、すべてのウェーブデータを一度に確認できます。 

テーブルに 3 次元ウェーブを表示すると、一度に 1 スライスずつしか表示・編集できません。 

これを確認するには、次のコマンドを実行します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit 

w3D.id 

最初に、レイヤーインデックスが 0 のウェーブのスライスが表示さ

れます。これは、ウェーブのレイヤー0 です。 

テーブルの上部/右隅に表示される次のレイヤーと前のレイヤーのア

イコン、またはキーボードショートカットを使用して、表示するレ

イヤーを変更することができます。  

1 次元ウェーブの行次元に適用される上向き矢印と下向き矢印キーになぞらえて、「上」は「前の層」（下位インデ

ックス）を、「下」は「次の層」（上位インデックス）を意味します。 

キーボードからレイヤーを変更するには、Alt+上矢印キーで前のレイヤーを表示し、Alt+下矢印キーで次のレイヤー

を表示します。 

Shift キーを押すと、アイコンと矢印キーの両方の方向が反転します。 
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表示したいレイヤーのインデックスがわかっている場合は、Ctrl キ

ーを押しながら次のレイヤーまたは前のレイヤーのアイコンをクリ

ックすることで、ダイアログに直接インデックスを入力することが

できます。  

4 次元ウェーブをテーブルに表示した場合でも、一度に 1 つのレイヤーのみを表示、編集することができます。 

上述のアイコンまたはキーボードショートカットを使用して、表示するレイヤーを変更することができます。 

4D ウェーブの前のチャンクを表示するには、上矢印アイコンをクリックしながら Al キーを押すか、Ctrl+Alt+上矢

印キーを押します。 

次のチャンクを表示するには、Alt キーを押しながら下向き矢印をクリックするか、Ctrl+Alt+下向き矢印キーを押し

ます。 

キーボードショートカットを使うほかに、ModifyTable コマンドを使って、使いたいレイヤーとチャンクを指定す

ることもできます。 

表示されている次元の変更 

テーブルで 3D ウェーブを最初に表示すると、行と列の平面でウェーブのスライスを表示します。 

ウェーブの行の次元はテーブルの垂直の次元にマッピングされ、ウェーブの列の次元はテーブルの水平の次元にマッ

ピングされます。 

レイヤーアイコンの右側に表示される Choose Dimensions アイコンを使うと、任意のウェーブの次元を縦のテー

ブルの次元に、その他の任意のウェーブの次元を横のテーブルの次元にマッピングするよう設定することができま

す。 

これはウェーブ内の任意の直交平面を表示および編集できるため、主に、次元 3 以上のウェーブを扱う場合に興味深

いものです。 

例えば、3D ウェーブから切り出したデータを含む新しいウェーブを作成することができます。 

テーブルの要素の変更（ModifyTable element）コマンド 

このセクションでは、ModifyTable の element キーワードを使って表示された次元の選択について説明します。 

3D と 4D のウェーブを編集し、異なる視点からそれらを見ることを徹底的に理解したいのでなければ、このことを

知る必要はありません。 

このセクションを理解する最善の方法は、表示されているすべてのコマンドを実行することです。 

Igor は、垂直テーブルのどの次元をマッピングするべきか、また、水平テーブルのどの次元をマッピングするべきか

を知る必要があります。 

さらに、次元 3 以上のウェーブについては、Igor は表示すべき残りの次元の要素を知る必要があります。 

コマンドの形式は次のとおりです。 

ModifyTable elements(<wave name>) = (<row>,<column>,<layer>,<chunk>) 

パラメーターは、ウェーブの行、列、レイヤー、チャンクの次元のうち、どの要素を表示するかを指定します。 

各パラメーターの値は、要素番号（0 以上）または特殊な値である場合があります。 

パラメーターのいずれかに使うことができる特別な値は 3 つあります。 

-1 現在の値から変更なしを意味します。 

-2 この次元をテーブルの垂直の次元にマッピングすることを意味します。 

-3 この次元をテーブルの水平の次元にマッピングすることを意味します。 

以下の説明を読む時には、最初のパラメーターはウェーブの行の表示方法を指定し、2 番目のパラメーターはウェー

ブの列の表示方法を指定し、3 番目のパラメーターはウェーブのレイヤーの表示方法を指定し、4 番目のパラメータ

ーはウェーブのチャンクの表示方法を指定することを覚えておいてください。 
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パラメーターを省略すると、デフォルト値の-1（変更なし）が適用されます。 

したがって、2D ウェーブを扱う場合は、最初の 2 つのパラメーターのみを指定し、最後の 2 つは省略できます。 

このコマンドの感覚をつかむために、まずは簡単な行列の例、2D ウ

ェーブから始めます。 

Make/O/N=(3,3) wave0 = p + 10*q 

Edit wave0.id 

テーブルを上から見ると、行列の行が見えます。テーブルを横から

見ると、行列の列が見えます。  

したがって、行の次元はテーブルの垂直の次元にマッピングされ、列の次元はテーブルの水平の次元にマッピングさ

れます。 

これはデフォルトのマッピングです。 

次のコマンドでこれを変更できます。 

ModifyTable elements(wave0) = (-3, -2) 

最初のパラメーターは、ウェーブの行をどのように表示したいかを

設定し、2 番目のパラメーターは、ウェーブの列をどのように表示

したいかを設定します。 

ウェーブは 2 次元しかないため、3 番目と 4 番目のパラメーターは

省略できます。 

 

 

 

 

 

 

この例の -3 は、ウェーブの行をテーブルの水平方向へマッピングすることを指定します。 

-2 は、ウェーブの列をテーブルの縦の次元にマッピングすることを指定します。 

ウェーブをデフォルトの表示に戻すには、次のコマンドを使います。 

ModifyTable elements(wave0) = (-2, -3) 

3D ウェーブを考えると、少し複雑になります。 

行と列の次元に加えて、3 つ目の次元、つまりレイヤーの次元があります。 

3D ウェーブを含むテーブルを最初に作成すると、そのウェーブのレイヤー0 のすべての行と列が表示されます。 

したがって、2D ウェーブと同様に、行の次元はテーブルの垂直の次元にマッピングされ、列の次元はテーブルの水

平の次元にマッピングされます。 

ここまで説明したアイコンやキーボードショートカット、または ModifyTable elements のキーワードを使って、

テーブルに表示する 3D ウェーブのレイヤーをコントロールすることができます。 

例えば： 

Make/O/N=(5,4,3) wave0 = p + 10*q + 100*r 

Edit wave0.id 

ModifyTable elements(wave0)=(-2, -3, 1) // Shows 

layer 1 of the 3D wave 

ModifyTable elements(wave0)=(-2, -3, 2) // Shows 

layer 2 of the 3D wave  

これらの例では、ウェーブのレイヤーの次元は特定の値に固定されていますが、テーブルを上から見たり、下から見

ると、ウェーブの行と列の次元は変化します。 

「自由次元」とは、テーブルの次元のいずれかにマッピングされるウェーブの次元を指します。 

「固定次元」とは、固定値を選択したウェーブの次元を指します。 

先の例では、行と列の平面における 3D ウェーブの一部分を観察しました。 

ウィンドウには任意の直交平面を表示することができます。 
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例えば、次のコマンドは、レイヤー・行平面のデータを表示するよ

うに指示します。 

ModifyTable elements=(-3, 0, -2)  // Shows 

column 0 of the 3D wave 

最初のパラメーターは、ウェーブの行の次元をテーブルの水平方向

の次元にマッピングすることを示しています。 

2 番目のパラメーターは、ウェーブの列 0 を見たいということを意

味します。 
 

3 番目のパラメーターは、ウェーブのレイヤーの次元をテーブルの垂直の次元にマッピングしたいということを意味

します。 

4D ウェーブを扱う場合は、2 つの自由次元に加えて 2 つの固定次元

があることを除いて、3D の場合と似ています。 

Make/O/N=(5,4,3,2) wave0 = p + 10*q + 100*r + 

1000*s 

Edit wave0.id 

ModifyTable elements(wave0)=(-2, -3, 1, 0) // 

Shows layer 1/chunk 0 

ModifyTable elements(wave0)=(-2, -3, 2, 1) // 

Shows layer 2/chunk 1 

 

 

 

 

 

 

 

ウェーブを変更（Make/O または Redimension を使う）して、自由次元の 1 つまたは両方がゼロポイントになるよ

うにした場合、Igor は自動的に表示をデフォルトにリセットします。 

例を示します。 

Make/O/N=(5,4,3) wave0 = p + 10*q + 100*r 

Edit wave0.id 

Modify elements(wave0) = (0, -2, -3)  // 

Map layers to horizontal dimension 

Redimension/N=(5,4) wave0    // 

Eliminate layers dimension! 

最後のコマンドで、テーブルの水平次元にマッピングされたウェー

ブ次元が削除されます。  

したがって、Igor は自動的にテーブル表示をリセットします。 

ゼロポイントの次元を自由次元として使うように設定すると、表示

はデフォルトにリセットされます。 

Make/O/N=(3,3) wave0 = p + 10*q 

Edit wave0.id 

Modify elements(wave0) = (0, -2, -3)  // 

Map layers to horizontal dimension 

最後のコマンドは、ウェーブのレイヤー次元をテーブルの水平次元

にマッピングします。 

 

 

 

 

 

 

しかし、ウェーブにはレイヤー次元がないため、表示をデフォルトにリセットします。 

キーボードショートカットを使って表示を変更するという本ヘルプの最初の議論は、説明を簡潔にするために不完全

なものでした。 

Alt+下矢印キーで次のレイヤーが表示され、Command+Option+下矢印キーまたは Ctrl+Alt+下矢印キーで次のチ

ャンクが表示されると書かれていました。 
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これは、行と列が自由次元である場合にも当てはまります。 

より一般的な説明としては、Option キーを押しながら下矢印キーを押すと、第 1 の固定次元の表示要素が変更さ

れ、Command キーと Option キーを押しながら下矢印キーを押すと、第 2 の固定次元の表示要素が変更されます。 

4D ウェーブを使った例です。 

Make/O/N=(5,4,3,2) wave0 = p + 10*q + 100*r + 

1000*s 

Edit wave0.id 

ModifyTable elements(wave0)=(0, -2, 0, -3) 

ModifyTable コマンドは、列とチャンクの次元が自由次元であるこ

とを指定します。 
 

行とレイヤーの次元は 0 に固定されています。 

ここで Option+下矢印キーまたは Alt+下矢印キーを押すと、最初の固定次元の要素が変更されます。 

この場合、行の次元です。 

Command+Option+下矢印キーまたは Ctrl+Alt+下矢印キーを押すと、2 番目の固定次元の要素が変更されます。

この場合、レイヤー次元です。 

 

多次元のコピー／カット／ペースト／クリア 

このセクションの内容は、主にテーブル内の 3D および 4D データを編集する時に役立つものです。 

2D データに関する項目もいくつかあります。 

テーブルのセルをコピーすると、Igor は 2 つの形式でデータをコピーします。 

⚫ Igor バイナリ：Igor ウェーブに貼り付け用 

⚫ プレーンテキスト：他のプログラムに貼り付け用 

1D および 2D ウェーブの場合、コピーしてペーストする部分はテーブルの選択から明らかです。 

3D および 4D ウェーブの場合、テーブルでは一度に 2 次元しか表示されず、その 2 次元のサブセットを選択するこ

とができます。 

プレーンテキストとしてコピーする場合、常に、表示されているセルのみをクリップボードにコピーします。 

Igor バイナリとしてコピーする場合、コピー中に Alt キーを押すと、すべての次元のセルをコピーします。 

次の例を考えてみます。 

5 行 4 列 3 レイヤーのウェーブを作成し、テーブルに表示します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D.id 

テーブルは、ウェーブのレイヤー0 のすべての行と列を表示します。 

表示されているデータセルをすべて選択してコピーすると、Igor はレイヤー0 のすべてをクリップボードにコピーし

ます。 

Option+copy または Alt+copy を行うと、Igor は 3 つのレイヤーすべてをクリップボードにコピーします。 

つまり、レイヤー0 と現在表示されていない 2 つのレイヤーを Igor バイナリ形式でコピーします。 

次の表は、Alt キーの効果を示しています。 

  コピー   ペースト    クリア 

なし  表示セルをコピー  表示セルを置換ペースト  表示セルをクリア 

Alt  すべてをコピー  すべてを置換ペースト  すべてをクリア 

上の表の真ん中の列には、「置換ペースト」と記載されています。 

ペーストを行うと、通常、テーブル内の選択部分をクリップボード内のデータで置き換えます。 

しかし、ペースト時に Shift キーを押すと、テーブルに新しいセルとしてデータを挿入します。 
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これは「挿入ペースト」と呼ばれます。 

次の表は、ペースト時の Alt キーの効果を示しています。 

  ペースト 

なし  表示セルを置換ペースト 

Alt  すべてを置換ペースト 

Shift  表示セルを挿入ペースト 

Shift+Alt すべてを挿入ペースト 

多次元データの置換ペースト 

テーブル内のデータをコピーし、そのテーブルまたは別のテーブル内のセルを選択してペーストを行うと、置換ペー

ストが行われます。 

コピーしたデータがペースト時に選択部分と置き換わります。 

1D および 2D ウェーブの場合、コピーしてペーストする部分はテーブルの選択から明らかです。 

3D および 4D ウェーブの場合、テーブルでは一度に 2 次元しか表示されず、その 2 次元のサブセットを選択するこ

とができます。 

3 次元以上のウェーブを含む通常の置換ペーストを行うと、クリップボード内のデータが、現在選択されているウェ

ーブの表示されているスライスのデータを置き換えます。 

3D ウェーブのレイヤーを別のレイヤーにコピー 

置換とペーストの例を以下に示します。 

1．5行 4列 3 段のウェーブを作り、テーブルに表示します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D 

テーブルには、ウェーブのレイヤー0 のすべての行と列が表示され

ます。 

ウェーブのレイヤー1 を見てみます。 

 

2．テーブルがアクティブな状態で、Alt+下矢印キーを押します。 

これにより、レイヤー0 ではなくレイヤー1 が表示されます。 

 

3．表示されているセルをすべて選択し、メニュー Edit → Copy

を選択します。 

これはレイヤー1 をすべてクリップボードにコピーします。 

 

4．Alt キーを押しながら下矢印キーをもう一度押して、ウェーブ

のレイヤー2 を表示します。 
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5．すべてのセルが選択された状態で、メニュー Edit → Paste

を選択します。 

レイヤー1 からコピーされたデータが、ウェーブのレイヤー2 のデ

ータを置き換えます。 
 

6．メニュー Edit → Undo Paste を選択します。 

レイヤー2 が元の状態に復元されます。 

 

7．Alt キーを押しながら上矢印キーを 2 回押します。 

これで、レイヤー0 が表示されます。 

 

8．メニュー Edit → Paste を選択します。 

レイヤー1 からコピーしたデータが、レイヤー0 のデータを置き換

えます。 

 

9．メニュー Edit → Undo Paste を選択してレイヤー0 を元の

状態に戻します。 

 

 

3D ウェーブのすべてのデータをコピー＆ペースト 

1 つのレイヤーだけでなく、すべてのウェーブデータをコピー＆ペーストする方法を示します。 

1．5行 4列 3 レイヤーのウェーブを作り、テーブルに表示しま

す。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D 

 

2．表示されているすべてのセルを選択します。 
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3．Alt キーを押しながら、メニュー Edit → Copy All Layers 

を選択します。 

（Alt キーを押すとメニュー項目が変わります） 

これにより、3 つのレイヤーすべてを含むウェーブ全体がクリップ

ボードにコピーされます。 

 

4．Alt キーを押しながら、メニュー Edit → Clear All Layers を選択します。 

これは３レイヤーすべてをクリアします。 

5．Alt+下矢印キーと Alt+上矢印キーで、3 つのレイヤーすべてがクリアされたことを確認します。 

6．Alt キーを押しながら、メニュー Edit → Paste All Layers を選択します。 

これは、クリップボード上の 3 つのレイヤーすべてを選択したウェーブに貼り付けます。 

7．Alt+下矢印キーと Alt+上矢印キーを使って、3 つのレイヤーすべてがペーストされたことを確認します。 

 

２つの 1D ウェーブから１つの 2D ウェーブを作成 

この例では、2 つの 1 次元ウェーブから 2 次元ウェーブを作成します。 

1．1D のウェーブを２つ作り、テーブルに表示します。 

Make/O/N=5 w1DA=p, w1DB=100+p; Edit w1DA, w1DB 

 

2．最初の 1D ウェーブ全体を選択して、メニュー Edit → Copy 

を選択します。 

 

3．テーブルの最初の未使用セルをクリックし、メニュー Edit →

Paste を選択します。 

未使用セルにペーストしたので、新しいウェーブが作成されまし

た。 

これが「作成ペースト」です。 
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4．Table ポップアップメニュー（歯車アイコン）から

Redimension w1DA1 を選択します。 

 

5．Redimension Waves ダイアログで、列の数を 2 と入力し、

Do It をクリックします。 

 

6．次元が変更されたウェーブの列名を右クリックし、Rename を

選択します。 

 

7．w1DA1 の名前を w2D に変えます。 

 

8．2 番目の 1D ウェーブ、w1DB のすべてを選択し、メニュー 

Edit → Copy を選択します。 

 

9．2D ウェーブの 2 番目の列のすべてを選択し、メニュー Edit→

Paste を選択します。 
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2 つの 1 次元ウェーブから生成された 2 次元ウェーブが現れまし

た。 

 

 

多次元データの挿入ペースト 

テーブル内のデータをコピーし、次にテーブルまたは別のテーブル内のセルを選択し、シフトキーを押しながらペー

ストを行うと、挿入ペーストを行います。 

コピーされたデータは、選択したセルの前の選択したウェーブまたは複数のウェーブに挿入されます。 

置換ペーストの場合と同様に、挿入ペーストも、Alt キーが押されていない場合は表示されているレイヤーのデータ

のみに、Alt キーが押されている場合はすべてのレイヤーに適用されます。 

次に、これを説明する例を示します。 

3D ウェーブに新しい行を挿入 

1．3D のウェーブを作り、テーブルに表示します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D 

 

2．テーブルの行 1 と行 2 のセルをすべて選択します。 

これを簡単に行うには、Row の列にある「1」をクリックし、「2」

まで下にドラッグします。 

 

3．メニュー Edit → Copy を選択して選択したセルをコピーし

ます。 

Alt キーを押していないため、これは表示されているレイヤーだけを

コピーします。 
 

4．Shift キーを押しながら、Edit メニューから Insert Paste を

選択して、コピーしたデータを挿入します。 

（Shift キーを押すとメニュー項目の名前が変わります） 

 

2 つの新しい行が挿入され、既存の行が下に押し下げられたことに

注目してください。 
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5．Alt キーを押しながら下矢印キーを押して、3D ウェーブのレイ

ヤー1 と 2 に挿入された内容を確認します。 

ゼロが挿入されたことに注目してください。これは、ペーストが表

示されていたレイヤーにのみデータを保存したためです。  

6．Alt+上矢印キーを押してレイヤー0 を再度表示します。 

メニュー Edit → Undo Paste を選択して、ペーストを元に戻し

ます。 

 

7．Alt+下矢印キーでウェーブの他のレイヤーを確認し、Alt+上矢印キーでレイヤー0 に戻ります。 

ウェーブは元の状態に戻りました。 
次に、すべてのレイヤーに挿入ペーストを行います。 

8．ウェーブの行 1、行 2 を選択します。 

Alt キーを押しながら、メニュー Edit → Copy All Layers を選

択します。 

これは、3 つのレイヤーすべてからクリップボードにデータをコピ

ーします。  

9．Shift+Alt キーを押して、メニュー Edit → Insert Paste 

All Layers を選択します。 

（Shift+Alt キーを押すとメニュー項目の名前が変わります） 

これは、クリップボードのデータをウェーブの 3 つのレイヤーすべ

てにペーストします。Shift キーを押すことで、置換ペーストではな

く挿入ペーストを行えます。Alt キーを押すことで、表示されている

レイヤーだけでなく、すべてのレイヤーにペーストします 

 

 

 

 

 

10．Alt+下矢印キーを使って、すべてのレイヤーにデータが貼り

付けられていることを確認します。 

 

行ではなく列をカット＆ペースト 

通常、データの行をカットし、ペーストします。 

しかし、列をカットし、ペーストしたい場合もあるでしょう。 

例えば、5 行 3 列の 2D ウェーブがある場合、そのウェーブの真ん中の列を切り取りたいと思うかもしれません。 

Igor は、行または列をカットするかどうかを次のように決定します。 

選択されたウェーブが 2D 以上であり、1 つ以上の列全体が選択されている場合、Igor は選択された列を切り取りま

す。 

それ以外の場合は、Igor は行を切り取ります。 

ウェーブデータのコピーまたはカットの後、クリップボードにデータが残ります。 

通常、ペーストを行うと、選択した行が上書きされるか、（Shift キーを押した場合は）新しい行が挿入されます。 
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列を挿入するには、以下の操作が必要です。 

1．挿入したい列をコピーします。 

 

2．正確に 1 つの列全体を選択します。 

列名をクリックすると、素早く選択できます。 

 

3．Shift キーを押しながら、Edit メニューから Insert Paste を

選択するか、Ctrl+Shift+V を押します。 

 

 

ウェーブデータが実数（複素数ではない）の場合、Igor は通常、選択した列の前に新しい列をペーストします。 

この操作では、ウェーブの最後の列の後に列をペーストする方法が

ありません。 

したがって、選択した列が最後の列である場合、新しい列を最後の

列の前または後にペーストするかどうかを決めるダイアログを表示

します。 
 

ウェーブデータが複素数の場合、選択された列が実数であれば新しい列をその前に、選択された列が虚数であればそ

の後に貼り付けます。 

複数の列を選択した場合、またはすべての列を選択していない場合、Igor は列の代わりに行を挿入します。 

多次元データの作成ペースト 

テーブル内のデータをコピーし、次にテーブル内の最初の未使用セルを選択し、次にペーストを行うと、1 つまたは

複数の新しいウェーブを作成します。 

作られるウェーブの数と各ウェーブの次元数は、コピーされたデータと同じです。 

Igor は、ウェーブの次のプロパティもコピーしてペーストします。 

⚫ データ単位と次元単位 

⚫ データのフルスケールと次元スケーリング 

⚫ 次元ラベル 

⚫ ウェーブのノート 

Igor は、ウェーブノート全体をコピーした場合にのみ、そのウェーブノートをコピーしてペーストします。 

ウェーブの一部をコピーした場合、ウェーブノートはコピーされません。 

作成ペーストを使うと、テーブルに表示されているデータのサブセットのコピーを作成できます。 

1D および 2D ウェーブの場合、コピーしてペーストするサブセットは、テーブルの選択から明らかです。 
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３次元以上のウェーブの場合、テーブルには一度に２次元しか表示できないため、その２次元の中からサブセットを

選択することができます。 

コピーしてから作成ペーストを行うと、コピーした時点で表示されていたデータのみを含む新しい 2D ウェーブを

作成します。 

Alt キーを押しながらコピーし（Copy All Layers）、作成ペーストを行うと、コピーしたものと同数の次元とデータ

を持つ新しいウェーブを作成します。 

3D ウェーブのスライスから 2D ウェーブを作成 

1．3D のウェーブを作り、テーブルに表示します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D 

 

2．3D ウェーブのセルをすべて選択し、メニュー Edit → Copy 

を選択します。 

 

3．最初の未使用のセルをクリックし、Edit → Paste を選択しま

す。 

 

列ラベルを見ると w3D1 という名前の新しい 2D ウェーブが作成

されたことがわかります。 

 

 

3D ウェーブから 3D ウェーブを作成 

1．3D のウェーブを作り、テーブルに表示します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D 
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2．3D ウェーブのセルをすべて選択します。 

 

3．Alt キーを押して、メニュー Edit → Copy All Layers を選

択します。 

 

4．最初の未使用のセルをクリックし、Edit → Paste を選択しま

す。 

これで、元の 3D ウェーブのすべてのレイヤーのデータで構成され

る 3D ウェーブ（w3D1）が完成しました。 

これを確認するため、新しいウェーブのすべての層を検査します。  

5．Alt+下矢印（次のレイヤーに移動）と Alt+上矢印（前のレイ

ヤーに移動）を押して、新しいウェーブの他のレイヤーを表示しま

す。 

 

 

3D ウェーブの列から 1D ウェーブを作成 

1．3D のウェーブを作り、テーブルに表示します。 

Make/O/N=(5,4,3) w3D = p + 10*q + 100*r; Edit w3D 

 

2．3D ウェーブのセルをすべて選択します。3D ウェーブの１つ

の列を選択して、メニュー Edit → Copy を選択します。 

 

3．最初の未使用のセルをクリックし、Edit → Paste を選択しま

す。 

１列のウェーブが作成されたようですが、実は、これは 2D ウェー

ブであり、1D ウェーブではありません。 
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4．テーブルポップアップメニュー（歯車アイコン）から

「Redimension w3D1」を選択すると、「ウェーブのサイズ変

更」ダイアログが表示されます。 

 

5．Redimension Waves ダイアログで、列の数に 0 を入力

し、Do It をクリックします。 

 

6．これで、3D ウェーブの列から 1D ウェーブが作成されまし

た。 

 

 

テーブルのコピーを保存 

アクティブなテーブルは、パックされた Experiment ファイル、またはタブ

またはカンマ区切りのテキストファイルとして保存することができます。 

これを行うには、メニュー File → Save Table Copy を選択してください。 

パックされた Experiment として保存する主な用途は、データのアーカイブ

コピーを保存すること、または複数の Experiment のデータをマージする準

備をすることです（ヘルプ Merging Experiments（Experiments, Files and 

Folders.ihf））。 

結果の Experiment ファイルには、テーブルに表示されているすべてのウェ

ーブの親フォルダーである「最上位」のデータフォルダーから、テーブルに

表示されているウェーブのデータフォルダーまでの階層構造が保持されま

す。  

一番上のデータフォルダーが、結果の Experiment ファイルのルートデータフォルダーになります。 

Experiment ファイルには、テーブルとそのウェーブのみが保存され、変数、文字列、その他のオブジェクトは保存

されません。 

Save Table Copy は依存関係をサポートしていません。 

テーブルに、テーブル内に表示されていない別のウェーブ wave1 に依存するウェーブ wave0 が含まれている場

合、Save Table Copy を選択すると、wave0 は保存されますが、wave1 は保存されません。 

保存した Experiment を開くと、依存関係に破損が発生します。 

タブ区切りまたはカンマ区切りテキストファイルとして保存する主な用途は、データを別のプログラムにエクスポー

トするためです。 

ポイント列は保存されません。 
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テキスト形式で保存する時、データ形式はテーブルに示された形式と一致します。 

これにより、元のデータがテーブルに示された精度よりも高い場合、データが切り捨てられます。 

データを完全な精度でテキストとして保存するには、メニュー Data → Save Waves → Save Delimited Text を

選択するか、/F=1 を指定して SaveTableCopy コマンドを使います。 

3D および 4D ウェーブをテキストとして保存する場合、表示されているレイヤーのみ保存されます。 

3D または 4D ウェーブ全体を保存するには、メニュー Data → Save Waves → Save Delimited Text を選択し

てください。 

SaveTableCopy コマンドでは、Save Table Copy メニューでは利用できないオプションが提供されます。 

 

テーブル内のオブジェクト参照ウェーブ 

このトピックは上級ユーザー向けです。 

オブジェクト参照ウェーブは、ウェーブ参照（WAVE ウェーブ）またはデータフォルダー参照（DFREF ウェーブ）

を含むウェーブです。 

オブジェクト参照ウェーブの要素は、デフォルトでは 16 進数でフォーマットされます。 

詳細については、本ファイル P37「オブジェクト参照ウェーブのフォーマット」を参照してください。 

無効な参照を入力するとクラッシュする可能性があるため、テーブルで編集してオブジェクト参照ウェーブの要素を

変更することはできません。 

オブジェクト参照ウェーブをテーブルに表示し、Table メニューから Show 

Column Info Tags をオンにして、オブジェクト参照ウェーブの要素にマウ

スカーソルを置くと、その要素が参照するウェーブまたはデータフォルダー

に関する情報を列情報タグに表示します。 

この機能は、列情報タグがオンになっている場合、デバッガーで動作しま

す。 

 

WAVE ウェーブでウェーブ参照を編集 

テーブルに WAVE ウェーブが表示されている場合、そのウェーブの１つまたは複数のセルを選択し、右クリックし

て コンテキストメニューから Edit Waves を選択します。 

Igor は、テーブル内の選択したウェーブ参照によって参照されるウェーブを表示する新しいテーブルを作成しま

す。 

テーブルのポップアップメニュー（テーブルの右上隅にある歯車アイコン）からも同じ操作を行うことができます。 

Edit Waves は、メインメニューバーの Table メニューには表示されません。 

Edit Waves は、１つ以上の編集可能なウェーブ参照が選択されている場合にのみ、コンテキストメニューまたはテ

ーブルのポップアップメニューに表示されます。 

NULL ウェーブ （ウェーブ参照=0） およびフリーウェーブは、テーブルでは編集できません。 

この機能は、デバッガーのテーブルサブウィンドウでは使用できません。 
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テーブルの印刷 

テーブルを印刷する前に、テーブルをデスクトップの上部に移動し、「ページ設定」ダイアログを使ってページサイ

ズと方向を設定してください。 

メニュー File → Page Setup for All Tables を選択してください。 

各 Experiment では、すべてのテーブルに対して１つのページ設定を保存します。 

したがって、テーブルがアクティブな状態でページ設定を変更すると、その Experiment のすべてのテーブルのペー

ジ設定が変更されます。 

「ページ設定」ダイアログを表示する時は、印刷したいテーブルが最前面のウィンドウであることを確認してくださ

い。 

グラフ、ページレイアウト、または他のウィンドウのページ設定を変更しても、テーブルのページ設定には影響しま

せん。 

テーブルの全体または一部を印刷できます。 

テーブル全体を印刷するには、１つのセルを選択し、メニュー File → Print Table を選択します。 

選択範囲を印刷するには、複数のセルを選択し、File メニューから Print Table を選択します。 

 

テーブルをグラフィックスとしてエクスポート 

テーブルは主にデータの編集を目的としていますが、プレゼンテーションにも使うことができます。 

ページレイアウトのヘルプで説明しているように、Igor のページレイアウトにテーブルを挿入することができま

す。 

このセクションでは、テーブルを画像として他のアプリケーションにエクスポートする方法について説明します。 

通常、この操作は、ワードプロセッサやページレイアウトソフトでレポートを作成する時や、イラストレーションソ

フトでイラストを作成する時に行います。 

テキストの書式設定機能が強力なプログラムにエクスポートする場合には、Edit メニューの Copy を使って、テーブ

ル内のデータをテキストとしてコピーする方が良い場合があります。 

テキストを他のプログラムにペーストし、その後、自由に整形できます。 

テーブルを画像としてエクスポートする 

テーブルを Macintosh 画像としてクリップボード経由でエクスポートするに

は、Edit メニューから Export Graphics を選択します。 

これにより、テーブルが画像としてクリップボードにコピーされます。 

Igor がクリップボードにコピーする画像には、テーブルウィンドウに表示さ

れているセルのみが含まれます。 

ウィンドウをスクロール、拡大、縮小して、画像に表示するセルをコントロ

ールすることができます。  

画像をクリップボードにコピーする代わりに、ファイルに書き出すことができます。 

これを行うには、メニュー File → Save Graphics を使います。 

ほとんどのワードプロセッサ、ドローイングソフト、ページレイアウトソフトでは、クリップボード経由またはファ

イル経由で画像をインポートすることができます。 

例えば、プレゼンテーション目的で最適化されていないテーブルに対して、プレゼンテーション用に使うことができ

る２つの機能をテーブルに特別に実装しました。 

まず、ポイント列の幅を 0 に設定することで、その列を非表示にできます。 
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次に、自動生成された列見出しを、自身で設定した列見出しに置き換えることができます。 

これらの両方に対しては、Modify Columns ダイアログを使ってください。 

実際には、プレゼンテーション用に便利な機能がいくつか不足しています。 

まず、表の背景色を変更できません。 

また、グリッド線を変更または削除することはできません。 

これらの操作を行いたい場合は、テーブルを編集可能な描画ソフトにエクスポートして、デザインを調整してくださ

い。 

 

テーブルのプレファレンス 

テーブルのプレファレンスでは、新しいテーブルを作成したり、既存のテーブルに新しい列を追加したりするときの

動作をコントロールできます。 

 

プレファレンスを設定するには、テーブルを作成し、必要な形に設定しま

す。 

これを「プロトタイプテーブル」と呼びます。 

次に、Table メニューから Capture Table Prefs を選択します。 

プレファレンスは通常、手動操作にのみ有効であり、プロシージャによる自

動操作には有効ではありません。 

この点については、ヘルプ How to Use Preferences（Using Igor.ohf）で

詳しく説明しています。  

Igor を最初にインストールすると、すべてのプレファレンスは出荷時のデフォルト設定になります。 

ダイアログには、変更したプレファレンスと出荷時のデフォルト設定が示されます。 

Window Position and Size のプレファレンスは、新しいテーブル

の作成にのみ影響します。 

Column Styles プレファレンスは、新しく作成されるテーブルおよ

び既存のテーブルに追加される列のフォーマットに影響します。 

このプレファレンスは、ポイント列と、もう１つの列（プロトタイ

プテーブルの ポイント列の後の最初の列）の列設定を保存します。 

新しいテーブルを作成したり、テーブルに列を追加したりする時、

これらの設定が列の書式設定を決定します。 
 

Page Setup のプレファレンスは、新しいテーブルを作成するときではなく、新しい Experiment を作成するときに

影響します。 

その理由は次のとおりです。 

各 Experiment では、その Experiment のすべてのテーブルについて１つのページ設定が保存されます。 

プレファレンスにも、テーブルの１つのページ設定が保存されます。 

テーブルの優先ページ設定を設定すると、現在の Experiment のテーブルのページ設定のコピーをプレファレンスフ

ァイルに保存します。 

新しい Experiment を作成すると、テーブルの優先ページ設定のコピーを Experiment に保存します。 

 



60 

 

テーブルスタイルマクロ 

テーブルスタイルマクロの目的は、同じスタイルのプロパティを持

つ複数のテーブルを作成できるようにすることです。 

Window Control ダイアログを使って、プロトタイプテーブルから

スタイルマクロを自動的に生成するように Igor に指示することがで

きます。 

その後、そのマクロを他のテーブルに適用することができます。 
 

Igor は、グラフ、テーブル、ページレイアウト用のスタイルマクロ

を生成することができます。 

ただし、その有用性は主にグラフに限られます。 

ヘルプ Graph Style Macros（Graphs.ihf）を参照してください。 

そこに説明された原則は、テーブル形式のマクロにも適用されま

す。 
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