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Volume II User’s Guide: Part1 （3D Graphics #1） 

概要 

Igor Pro マニュアル：II-406 ページ以降をもとに編集 

 

Igor では、さまざまな 3D グラフィックスを作成できます。 

⚫ Surface Plots 

⚫ 3D Scatter Plots 

⚫ 3D Bar Plots 

⚫ Path Plots 

⚫ Ribbon Plots 

⚫ Isosurface Plots 

⚫ Voxelgram Plots 

画像プロット、等高線プロット、ウォーターフォールプロットは 2D グラフィックスとみなされ、ヘルプやマニュ

アルの他のセクションで説明されています。 

Igor の 3D グラフィックスツールは「Gizmo（ギズモ）」と呼ばれています。 

Gizmo で作成する 3D グラフィックスのほとんどは、ウェーブに保存されたデータに基づいています。 

どのようなタイプの 3D グラフィックスにどのようなタイプのウェーブデータが必要なのかを理解することが重要

です。 

以降のセクションで説明していきます。 

 

1D ウェーブ 

1D ウェーブは 3D プロットに使うことができません。 

X、Y、Z 座標を表す３つの 1D ウェーブを 3D プロットとして表示したい場合は、それらをトリプレットウェーブ

に変換する必要があります。 

例えば、次のようになります（詳細は後で説明します）。 

1．新しい Experiment を作成して、コマンドウィンドウで次を

実行して、3 つの 1D ウェーブを作成します。 

Make/N=10/D xWave,yWave,zWave 

xWave = sin(x)  

yWave = sin(x)  

zWave = cos(x) 

 

2．次のコマンドを実行して、トリプレットフィールドに変換しま

す。 

Concatenate {xWave,yWave,zWave}, tripletWave 
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3．Data Browser で、作成したトリプレットフィールドを右ク

リックして、New Gizmo Plot を選択します。 

 

4．右のような 3D プロットが作成されます。 

マウスでプロットを回転させてみてください。 

 

３つの 1D ウェーブをトリプレットウェーブに変換することは、データが長方形のグリッドでサンプリングされて

いない場合に適しています。 

データが長方形のグリッドでサンプリングされていることがわかっている場合は、Z データを含むウェーブを 

Redimension コマンドで 2D ウェーブを使ってサーフェスをプロットします。 

この変換は、例えば、次のコマンドを使って実行できます。 

Duplicate/O zWave, zMatrixWave 

Redimension/N=(numRows,numColumns) zMatrixWave 

 

2D ウェーブ 

2D ウェーブは、時々「Z 値の行列」とも呼ばれ、M 列 N 行のウェーブで、各要素がスカラー値 Z を表します。 

ウェーブのスケーリング（マニュアル II-62 Waveform Model of Data を参照）を適用して、各行に X 値を、各

列に Y 値を関連付けることができます。 

2D ウェーブは、サーフェスプロットおよび 3D 棒グラフで 3D グラフィックスとして表示することができます。 

（2D ウェーブは、画像プロット、等高線プロット、ウォーターフォールプロットの 2D グラフィックスとしても表

示できます。） 

 

トリプレットウェーブ 

トリプレットウェーブは、各行に XYZ トリプレットを含む 3 列の M 行のデータです。 

X 値は最初の列に、Y 値は 2 番目の列に、Z 値は 3 番目の列に表示されます。 

トリプレットウェーブとは、X、Y、Z の座標を含む 2D ウェーブと解釈されます。 

トリプレットウェーブは、3D 散布図、3D サーフェスプロット、3D パスプロット、3D リボンプロットで 3D グ

ラフィックスとして表示することができます。 

サーフェスプロットでは、トリプレットウェーブは表面上の三角形を定義します。 

（トリプレットウェーブは、等高線プロットで 2D グラフィックスとして表示することもできます） 
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3D ウェーブ 

3D ウェーブは、ボリュームと呼ばれることもあり、M 列×N 行×L 層のウェーブで、各要素がスカラー値 Z を表し

ます。 

3D グラフィックスで使うには、3D ウェーブには各次元で少なくとも 2 つの要素を含める必要があります。 

3D ウェーブは、サーフェスプロット、等値面プロット、ボクセルグラムプロットで 3D グラフィックスとして表示

できます。 

（3D ウェーブは、3D ウェーブの１つのレイヤーが画像として表示される画像プロットで、2D グラフィックスと

して表示することもできます） 
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Gizmo の概要 

 

Igor の 3D プロットツールは「Gizmo（ギズモ）」と呼ばれています。 

Gizmo は、3D グラフィックスの業界標準システムである OpenGL をベースとしています。 

Gizmo は、Igor のデータとコマンドを OpenGL のデータと命令に変換し、その結果を「Gizmo ウィンドウ」と

呼ばれる Igor のウィンドウに表示します。 

Gizmo ウィンドウを作成するには、メニュー Windows → New → 3D Plot を選択し、Gizmo メニューを使って

グラフィックオブジェクトを追加します。 

OpenGL の知識がなくてもこれを行うことができます。 

このレベルでは、サーフェスプロット、散布図、パスプロット、ボクセルグラム、等値面プロット、3D 棒グラフ、

3D 円グラフを作成できます。 

このようなオブジェクトは、次に説明する描画オブジェクトと区別するために、「ウェーブベースのオブジェクト」

または「データオブジェクト」と呼びます。 

基本的なプロットを作成した後、Gizmo の情報ウィンドウを使ってさまざまなプロパティを変更することができま

す。 

上級ユーザーは、直線、三角形、四角形、立方体、球体、円柱、円盤、四面体、円錐などの 3D プリミティブのセ

ットを使ってグラフィックスを構築することもできます。 

このようなオブジェクトは、ウェーブベースのオブジェクトと区別するために、「ドローイングオブジェクト」と呼

びます。 

適切なスケーリングを適用すれば、描画オブジェクトとウェーブベースのオブジェクトを同じ Gizmo ウィンドウに

組み合わせることができます。 

Gizmo は、照明効果、光沢、テクスチャなどの高度な OpenGL 機能をサポートしています。 

高度な 3D グラフィックスを作成したい上級ユーザーは、3D グラフィックス全般、特に OpenGL を知っていると

役立つでしょう。 

 

システム要件 

Gizmo の動作の多くは、使用しているコンピューターのグラフィックハードウェアとグラフィックドライバーソフ

トウェアに依存しています。 

Gizmo を実行するには、VRAM 512MB 以上のグラフィックカードを搭載したハードウェアを推奨します。Gizmo 

は、オンボードグラフィックスと共有メモリを搭載したコンピューターでも動作しますが、パフォーマンスが低下

し、グラフィックスをエクスポートするときにエラーが発生する場合があります。 

 

ハードウェア互換性 

Gizmo グラフィックスは、実行中の OpenGL のバージョンに影響を受ける場合があります。 

これは、グラフィックハードウェア、グラフィックドライバーのバージョン、グラフィックアクセラレーションの設

定によって異なります。 
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Gizmo ガイドツアー 

 

以下のセクションのチュートリアルでは、Gizmo の基本的な機能、基本的な Gizmo プロットの作成方法、特定の

種類のプロットのデータの種類について理解を深めることができます。 

ツアーのさまざまなポイントで、Igor のコマンドの実行が指示されます。 

これを行うもっとも簡単な方法は、このマニュアルを使うのではなく、メニュー Help → Help Windows → 3D 

Graphics の項を開き、ヘルプファイルでのツアーを行うことです。 

ヘルプファイルでコマンドを選択し、Ctrl-Enter キーを押すことでそのコマンドを実行することができます。 

 

Gizmo 3D 散布図ツアー 

このツアーでは、XYZ データを含むトリプレットウェーブを作成し、それを 3D 散布図としてプロットします。 

1．メニュー File → New Experiment を選択して、新しい 

Experiment を作成します。 

 

2．次のコマンドを実行して、XYZ 散布データを持つトリプレッ

トウェーブを作成します。 

Make/O/N=(20,3) data = gnoise(5) 

data[][2] = 2*data[p][0] - 3*data[p][1] + data[p][0]^2 

+ gnoise(0.05) 

この散布データは、X と Y の多項式関数にほぼ等しい Z 値を持

つ XY 平面内のランダムな位置を示しています。 

 

 

 

 

 

3．このデータを Gizmo に表示するもっとも簡単な方法は、

Data Browser でこのデータを右クリックして Gizmo Plot を選

択することです。 

メニュー Data → Data Browser を選択します。 

（既に開いているかもしれません） 

 

4．data ウェーブのアイコンを右クリックして、New Gizmo 

Plot を選択します。 
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5．Gizmo0 という名前の新しいウィンドウで、data ウェーブか

ら Gizmo 3D 散布図を作成しました。 

また、Gizmo0 Info というタイトルで Gizmo 情報ウィンドウも

作成しました。 

（Gizmo0 Info ウィンドウが表示されていない場合は、メニュー 

Gizmo → Show Info を選択してください） 

Gizmo 散布図は、Gizmo0 ウィンドウ内のプロットをドラッグ、

回転したり、矢印キーを使うことでも回転させることができます。 

自由に操作してみてください。 

 

 

 

 

 

 

 

 

ここまではあまりにも簡単すぎて、参考にならないかもしれません。 

そこで、Data Browser のショートカットを使わずにやり直してみます。 

1．File → New Experiment を選択して、新しい 

Experiment を作成します。 

 

2．次のコマンドを実行して、XYZ 散布データを持つトリプレッ

トウェーブを作成します。 

Make/O/N=(20,3) data = gnoise(5) 

data[][2] = 2*data[p][0] - 3*data[p][1] + data[p][0]^2 

+ gnoise(0.05) 

この散布データは、X と Y の多項式関数にほぼ等しい Z 値を持

つ XY 平面内のランダムな位置を示しています。 

 

 

 

 

 

3．メニュー Windows → New → 3D Plot を選択します。 

コマンドウィンドウの履歴領域に次のコマンドがあることに注目し

てください 

NewGizmo 

Igor は、Gizmo0 の空のウィンドウと Gizmo0 Info ウィンドウ

も作成しました。 

（Gizmo0 Info ウィンドウが表示されていない場合は、メニュー 

Gizmo → Show Info を選択してください） 

 

 

 

 

 

 

 

 

 

 

4．Gizmo0 Info ウィンドウの Object List（中央）の下にあ

る「+」アイコンをクリックし、Scatter を選択します。 

Scatter Properties ダイアログが開きます。 
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5．Scatter Wave メニューから data を選択します。 

このメニューでは、トリプレットウェーブのみが表示されます。

3D 散布図を作成するには、トリプレットウェーブが必要です。 

他にもいくつかのオプションがありますが、今回はデフォルトのま

まにしておきます。 

 

6．Do It をクリックします。 

Igor は scatter0 という名前の 3D 散布オブジェクトを作成し、

それを情報ウィンドウの Object List に追加しました。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 
 

7．scatter0 オブジェクトを Object List から Display List 

にドラッグします。 

XYZ データを表す球体が Gizmo0 ウィンドウに表示されます。 

プロットは完全ではありませんが、Gizmo0 ウィンドウをクリッ

クしてドラッグすると、表示を回転させることができます。 
 

8．Gizmo0 Info ウィンドウで、Object List の下にある「+」

アイコンをクリックし Axes を選択します。 

Axes Properties ダイアログが表示されます。 

 

9．選択されていない場合は、Axis タブを選択します。Axis 

Type ポップアップメニューは Box に設定し、すべての軸のチェ

ックボックス（X0、X1、…Z2、Z3）にチェックを入れます。 
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10．Do It をクリックします。 

Igor は、axes0 という名前の axes オブジェクトを作成し、それ

を情報ウィンドウの Object List に追加しました。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 

 

 

 

 

 

 

11．axes0 オブジェクトを Object List から Display List 

にドラッグします。 

散布した球の周りに箱型の軸が追加されました。 

 

12．Object List または Display List のどちらかで、axes0 

オブジェクトをダブルクリックします。 

Axes Properties ダイアログが再び開きます。 

Ticks and Labels タブをクリックします。 

 

13．Axis ポップアップメニューから X0 を選択し、Show 

Tick Marks と Show Numerical Labels のチェックボックス

をオンにします。 

Axis ポップアップメニューから Y0 を選択し、Show Tick 

Marks と Show Numerical Labels のチェックボックスをオン

にします。 

Axis ポップアップメニューから Z0 を選択し、Show Tick 

Marks と Show Numerical Labels のチェックボックスをオン

にします。 

 

 

 

 

 

 

 

 

 

14．Do It をクリックします。 

X0、Y0、Z０ 軸に目盛ラベルが付けられました。 

しかし、どの軸がどれなのでしょうか？ 
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15．Gizmo0 ウィンドウのどこかを右クリックし、Show Axis 

Cue を選択します。 

 

16．どの次元がどれであるかを示す軸のヒントが追加されます。 

表示を少し回転させて、軸のキューの感覚を把握することができま

す。 

 

17．もう一度、情報ウィンドウで axes0 オブジェクトをダブル

クリックして、Axis タブを選択します。 

プロパティのダイアログにはボックスの軸が表示されます。 

マウスカーソルを軸の上に移動させると、軸を識別するツールチッ

プが表示されます。 

 

18．Gizmo0 Info ウィンドウのクローズボックスをクリックし

ます。 

Gizmo0 Info ウィンドウが隠れます。 

通常、3D プロットの作成や調整を行っている間は表示しておき、

プロットの表示のみを行いたい場合は非表示にすることができま

す。 

メニュー Gizmo → Show Info を選択するか、Gizmo0 ウィン

ドウを右クリックして Show Info Window を選択することで、

いつでも表示することができます。 
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19．Gizmo0 ウィンドウのクローズボックスをクリックしま

す。 

Close Window ダイアログが表示され、ウィンドウを再作成する

マクロとして保存するかを聞いてきます。 

これは、グラフの再作成マクロと同じように動作します。 

 

 

 

 

 

 

20．Save ボタンをクリックしてウィンドウ再作成マクロを保存

します。 

再作成マクロは、メインの Procedure Window に保存されま

す。 

メニュー Windows → Procedure Windows → Procedure 

Window を選択します。 

 

21．これは、Gizmo0 再作成マクロを含むメイン Procedure 

Window を表示します。 

冒頭部分を見るには、上までスクロールする必要があるかもしれま

せんが、冒頭は次のようになっています： 

Window Gizmo0() : GizmoPlot 

クローズボックスをクリックして Procedure Window を閉じま

す。 

 

 

 

 

 

 

 

 

 

22．メニュー Windows → Gizmo Macros → Gizmo0 を選

択します。 

Igor は、Gizmo0 再作成マクロを実行し、Gizmo0 ウィンドウを

再表示します。 

 

23．メニュー File → Save Experiment を選択して、

「Gizmo 3D Scatter Plot Tour.pxp」として、Experiment 

を保存します。 

これは、後でツアーを再度確認したい場合に備えたもので、厳密に

は必要ありません。 

 

 

 

 

 

 

これで、3D 散布図の作成は完了です。 

気づいているかもしれませんが、まだ紹介していない散布図や軸のオプションが数多くあります。 

Gizmo Info ウィンドウ内の scatter0 と axes0 アイコンをダブルクリックすることで、この時点で実行すること

ができます。 

または、保存しておいて、ガイドの次のセクションに進むこともできます。 
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Gizmo サーフェスプロットツアー 

このツアーでは、Z 値を含む 2D ウェーブを作成し、それをサーフェスプロットとしてプロットします。 

1．メニュー File → New Experiment を選択して、新しい 

Experiment を作成します。 

 

2．次のコマンドを実行して、Z 値を持つ 2D ウェーブを作成し

ます。 

Make/O/N=(100,100) data2D = Gauss(x,50,10,y,50,15) 

このマトリックスは、規則的なグリッド上の Z 値を表していま

す。 

 

 

 

 

 

最初のツアーで見たように、このデータを Gizmo に表示するもっとも簡単な方法は、Data Browser で適切なウ

ェーブを右クリックし、メニューから Gizmo Plot を選択することです。 

同じショートカットは、Z 値の行列でも使うことができます。 

しかし、Gizmo についてより深く理解してもらうため、あえて難しい方法で説明します。 

3．メニュー Windows → New → 3D Plot を選択します。 

コマンドウィンドウの履歴領域に次のコマンドがあることに注目し

てください 

NewGizmo 

Igor は、Gizmo0 の空のウィンドウと Gizmo0 Info ウィンドウ

も作成しました。 

 

4．Gizmo0 Info ウィンドウの Object List の下にある「+」

アイコンをクリックし、Surface を選択します。 

Surface Properties ダイアログが表示されます。 

 

5．Source Wave Type ポップアップメニューから Matrix を

選択し、Surface Wave ポップアップメニューから data2D を

選択します。 

他にもいくつかのオプションがありますが、今回はデフォルトのま

まにしておきます。 
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6．Do It をクリックします。 

Surface0 という名前のサーフェスオブジェクトが作成され、Info 

ウィンドウの Object List に追加されました。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 

 

 

 

 

 

 

7．surface0 オブジェクトを Object List から Display List 

にドラッグします。 

サーフェスが Gizmo0 ウィンドウに表示されます。 

現在は上面から見ています。 

 

8．マウスを使って、Gizmo0 ウィンドウ内のサーフェスを回転

させ、ガウスピークの側面が見えるように向きを変えます。 

 

9．Gizmo0 Info ウィンドウで、Object List の下にある「+」

アイコンをクリックし Axes を選択します。 

Axes Properties ダイアログが表示されます。 

 

10．選択されていない場合は、Axis タブを選択します。 

Axis Type ポップアップメニューは Box に設定し、すべての軸

のチェックボックス（X0、X1、…Z2、Z3）にチェックを入れま

す。 
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11．Do It をクリックします。 

Igor は、axes0 という名前の axes オブジェクトを作成し、それ

を情報ウィンドウの Object List に追加しました。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 

 

 

 

 

 

 

 

12．axes0 オブジェクトを Object List から Display List 

にドラッグします。 

サーフェスプロットの周りに箱型の軸が追加されました。 

 

13．Object List または Display List のどちらかで、axes0 

オブジェクトをダブルクリックします。 

Axes Properties ダイアログが再び開きます。 

Ticks and Labels タブをクリックします。 

X0、Y0、Z0 軸の目盛と目盛ラベルをオンにします。 

これは前のツアーで行ったことと同じです。 
 

14．次にカラースケールのアノテーションを追加します。 

メニュー Gizmo → Add Annotation を選択します。 

Add Annotation ダイアログが表示されます。 

 

15．ダイアログの左上にある Annotation ポップアップメニュ

ーから、ColorScale を選択します。 

 

16．Position タブをクリックし、Anchor ポップアップメニュ

ーを Right Center に設定します。 
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17．ColorScale Main タブをクリックし、次のコントロールを

設定します。 

Color Table: Rainbow 

Axis Range/Top: 100 

Axis Range/Bottom: 0 

 

18．Do It をクリックします。 

カラースケールのアノテーションが作成されます。 

目盛ラベルが、サーフェスプロットの Z 軸目盛ラベルと一致しな

いことに注意してください。 

データの範囲に合わせてカラースケールの範囲を設定する必要があ

ります。 

カラースケールを作成したコマンドを再実行することでこれを実行

します。 

 

19．コマンドウィンドウの履歴領域にある最後のコマンドをクリ

ックし、Enter キーを押してコマンドラインにコピーします。 

コマンドラインには、次のように表示されているはずです（設定し

た項目により異なる場合があります）： 

ColorScale/C/N=text0/F=0/S=3/A=RC  

ctab={0,100,Rainbow,0},axisRange={0,100} 

 

 

 

 

 

20．次に示すように ctab を変更し、Enter キーを押して実行

します。 

ColorScale/C/N=text0/F=0/S=3/A=RC  

ctab={WaveMin(data2D),WaveMax(data2D),Rainbow,0} 

これで、カラースケールの目盛とサーファスプロット内の Z 軸目

盛ラベルが一致しました。 

カラースケールの最大が 100 であり、対応が見にくいため、追加

で次を実行することを勧めます。 

ColorScale/C/N=text0  ctab={0,0.0011,Rainbow,0} 

ColorScale/C/N=text0 axisRange={,0.001} 

 

 

 

 

 

 

 

 

 

 

 

 

21．Gizmo0 Info ウィンドウの Object List の下にある

「+」アイコンをクリックし、Image を選択します。 

Gizmo Image Properties ダイアログが表示されます。 

 



16 

 

22．Source Type を 2D Matrix of Z-Values に設定し、

Source Wave ポップアップメニューから data2D を選択しま

す。 

サーフェスプロットと画像の両方で、同じウェーブをソースとして

使います。 

 

23．Initial Orientation ポップアップメニューから、XY 

Plane Z=0 を選択します。 

 

24．Translate 以外のチェックボックスをすべてオフにし、

Translate の X、Y、Z 成分をそれぞれ 0、0、-1 に設定しま

す。 

Z 方向への変換は、画像をディスプレイボリューム（表示の 3 次

元空間）の中心からディスプレイボリュームの面に移動させ、サー

フェスプロットに配置します。 

 

25．Do It をクリックします。 

image0 という名前の画像オブジェクトが作成され、情報ウィンド

ウの Object List に追加されます。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 

 

 

 

 

 

 

26．image0 オブジェクトを Object List から Display List 

にドラッグします。 

サーフェスプロットに対応した画像プロットが表示されました。 

表示を確認するには、回転させる必要があるかもしれません。 
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27．Object List の image0 オブジェクトをダブルクリック

し、Translate Z を -1.5 に設定し、Do It をクリックします。 

 

28．これにより、画像プロットとサーフェスプロットが分離され

見やすくなります。 

Translate パラメーターは、軸の単位ではなく、+/-1 のディスプ

レイボリュームの単位で示します。 

ディスプレイボリュームの単位は、特に球やボックスなどの描画扱

うときに、多くの場面で使われます。 

 

29．メニュー File → Save Experiment を選択して、

Experiment を「Gizmo Surface Plot Tour.pxp」として保存

します。 

これは、後でツアーを再度確認したい場合に備えたもので、厳密に

は必要ありません。 
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Gizmo 3D 散布図＆カーブフィッティングサーフェスツアー 

このツアーでは、トリプレットウェーブから 3D 散布図を作成し、カーブフィッティングを実行し、カーブフィッ

ト出力が元の散布データとどのように関連しているかを表すサーフェスを追加します。 

1．メニュー File → New Experiment を選択して、新しい 

Experiment を作成します。 

 

2．次のコマンドを実行して、XYZ 散布データを持つトリプレッ

トウェーブを作成します。 

Make/O/N=(20,3) data = gnoise(5) 

data[][2] = 2*data[p][0] - 3*data[p][1] + data[p][0]^2 

+ gnoise(0.05) 

この散布データは、X と Y の多項式関数にほぼ等しい Z 値を持

つ XY 平面内のランダムな位置を示しています。 

 

 

 

 

 

3． メニュー Data → Data Browser を選択します。 

（既に開いているかもしれません） 

このデータを Gizmo に表示するもっとも簡単な方法は、Data 

Browser でこのデータを右クリックして Gizmo Plot を選択する

ことです。 

 

4．data ウェーブのアイコンを右クリックして、New Gizmo 

Plot を選択します。 

 

5．Gizmo0 という名前の新しいウィンドウで、データウェーブ

から Gizmo 3D 散布図が作成されます。 
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6．コマンドラインで次を実行します。 

CurveFit/Q poly2d 2, data[][2]/X=data[][0,1] /D 

Igor は 2D 多項式カーブフィッティングを実行し、出力ウェーブ

と変数を生成します。 

主な出力は、fit_data ウェーブです。 
 

7．Data Browser ウィンドウを閉じます。 

これは単に画面をすっきりさせるためです。 

閉じなくても構いません。 

次に、Gizmo プロットにサーフェスを追加します。 

 

8．Gizmo0 Info ウィンドウの Object List の下の「+」アイ

コンをクリックし、Surface を選択します。 

Surface Properties ダイアログが表示されます。 

 

9．Source Wave Type ポップアップメニューから Matrix を

選択し、Surface Wave ポップアップメニューから fit_data を

選択します。 

他にもいくつかのオプションがありますが、今回はデフォルトのま

まにしておきます。 

 

10．Do It をクリックします。 

surface0 という名前の画像オブジェクトが作成され、情報ウィン

ドウの Object List に追加されます。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 
 

11．surface0 オブジェクトを Object List から Display List 

にドラッグします。 

サーフェスが Gizmo0 ウィンドウに表示され、散布オブジェクト

にうまくフィットしているように見えます。 
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12．マウスを使って、Gizmo プロットの内容を回転させて、さ

まざまな角度からフィットぐあいを確認します。 

 

13．メニュー File → Save Experiment を選択して、

Experiment を「Gizmo 3D Scatter Plot and Fitted 

Surface Tour.pxp」として保存します。 

これは、後でツアーを再度確認したい場合に備えたもので、厳密に

は必要ありません。 
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Voronoi 補間を使った Gizmo サーフェスツアー 

Z 値の 2D 行列からサーフェスプロットを作る方法は、すでに説明しました。 

このツアーでは、XYZ 散布データの 3D サーフェス表示をプロットする方法を説明します。 

このプロセスでは、Voronoi 補間を使って XYZ データの三角形分割を行います。 

1．メニュー File → New Experiment を選択して、新しい 

Experiment を作成します。 

 

2．次のコマンドを実行して、XYZ 散布データを持つトリプレッ

トウェーブを作成します。 

Make/O/N=(20,3) data = gnoise(5) 

data[][2] = 2*data[p][0] - 3*data[p][1] + data[p][0]^2 

+ gnoise(0.05) 

この散布データは、X と Y の多項式関数にほぼ等しい Z 値を持

つ XY 平面内のランダムな位置を示しています。 

 

 

 

 

 

3． メニュー Data → Data Browser を選択します。 

（既に開いているかもしれません） 

このデータを Gizmo に表示するもっとも簡単な方法は、Data 

Browser でこのデータを右クリックして Gizmo Plot を選択する

ことです。 

 

4．data ウェーブのアイコンを右クリックして、New Gizmo 

Plot を選択します。 

 

5．Gizmo0 という名前の新しいウィンドウで、データウェーブ

から Gizmo 3D 散布図が作成されます。 
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6．コマンドラインで次を実行します。 

ImageInterpolate/S={-5,0.1,5,-5,0.1,5}/CMSH 

Voronoi data 

Voronoi 補間は 2 つのウェーブ（M_ScatterMesh と 

M_InterpolatedImage）を作成します。 

M_ScatterMesh は、散布データをフィッティングする 3D 空間

内のポリゴンを定義する一連の XYZ 座標で構成されています。 

 

7．M_ScatterMesh を使って、3D プロットにサーフェスを追加

します。 

Gizmo0 Info ウィンドウの Object List の下にある「+」アイ

コンをクリックし、Surface を選択します。 

Surface Properties ダイアログが表示されます。 
 

8．Source Wave Type ポップアップメニューから Triangles 

を選択し、Surface Wave ポップアップメニューから 

M_ScatterMesh を選択します。 

他にもいくつかのオプションがありますが、今回はデフォルトのま

まにしておきます。 

 

9．Do It をクリックします。 

surface0 という名前の画像オブジェクトが作成され、情報ウィン

ドウの Object List に追加されます。 

まだ Display List には追加していないため、Gizmo0 ウィンドウ

には表示されていません。 
 

10．surface0 オブジェクトを Object List から Display List 

にドラッグします。 

サーフェスが Gizmo0 ウィンドウに表示されます。 
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11．マウスを使って、Gizmo プロットの内容を回転させて、さ

まざまな角度からフィットぐあいを確認します。 

 

12．Display List の surface0 オブジェクトをダブルクリック

し、Grid Lines and Points タブをクリックし、Draw Grid 

Lines チェックボックスにチェックを入れ、Do It をクリックし

ます。 

 

13．これは Voronoi 補間によって作成されたポリゴンを 

M_ScatterMesh ウェーブで表示したものです。 

 

14．コマンドラインで次を実行して、クリーンアップします。 

KillWaves M_InterpolatedImage 

Rename M_ScatterMesh, VoronoiMesh 

Igor が作成したデフォルトのウェーブ名を残しておくと、後で同

じデフォルトのウェーブ名を使う別のコマンドを実行しても、誤っ

てデータを上書きしてしまうことがありません。 

また、M_InterpolatedImage ウェーブはもう不要です。 
 

13．メニュー File → Save Experiment を選択して、

Experiment を「Gizmo Surface Using Voronoi 

Interpolation Tour.pxp」として保存します。 

これは、後でツアーを再度確認したい場合に備えたもので、厳密に

は必要ありません。 
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