
1 

 

CONTENTS 

Volume II User’s Guide: Part 1 （Graphs #4） ............................................................................................................ 2 

対数軸 ..................................................................................................................................................................................................... 2 

日付/時刻軸 .......................................................................................................................................................................................... 4 

フェイク軸 ............................................................................................................................................................................................ 9 

軸ラベル ...............................................................................................................................................................................................10 

グラフ内のアノテーション ............................................................................................................................................................14 

情報パネルとカーソル ....................................................................................................................................................................15 

トレースの特定 .................................................................................................................................................................................20 

サブレンジ（範囲の一部）の表示 ..............................................................................................................................................21 

グラフの印刷 ......................................................................................................................................................................................23 

グラフのコピーを保存 ....................................................................................................................................................................25 

グラフのエクスポート ....................................................................................................................................................................26 

 

 

  



2 

 

Volume II User’s Guide: Part 1 （Graphs #4） 

対数軸 

Igor Pro マニュアル：II-315 ページ以降をもとに編集 

 

対数軸を作るには、Modify Axis ダイアログの Axis タブで軸モ

ードを Log に設定します。 

 

 

 

通常の対数軸では、計算されたマニュアルの目盛やゼロの線はサポートされていません。 

Igor は、対数軸の目盛を 3 つの方法（通常、小範囲、大範囲）で刻むことができます。これは、軸の範囲（decade 

の数）に応じて使われます。 

通常モードは、decade の数が約 1/3 から約 10 までの間にある時に使います。 

正確な上限は、軸の物理的なサイズとフォントのサイズによって異なります。 

範囲の decade の数が、2 未満または 5 より大きい場合、LogLin チェックボックスをオンにすると、小範囲／大

範囲の方法を使うことができます。 

これにより、小範囲または非常に大きな範囲を持つ対数軸に対して良い結果が得られる場合があります。 

これを実行すると、手動の目盛を含む線形軸の設定のすべてが有効になります。 

これが、0.5 から 30 までの範囲の通常の対数軸です。 

 

1.5 から 4.5 の範囲にズームインすると、こうなります。 

 

しかし、LogLin チェックボックスをオンにすると、より良い結果を得られます。 
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対数軸を選択すると、Tick Options タブの Log Ticks セクショ

ンが使えるようになります。 

 

 

Max log cycles with minor ticks 設定は、対数軸に小数目盛を表示するかどうかをコントロールします。 

この設定は、0 から 20 の範囲で、デフォルトは 0 です。 

0 または auto の場合、Igor は自動的に補助目盛が適切かどうかを判断します。 

そうでなければ、軸がこの数値よりも多い decade を持つ場合、補助目盛は表示されません。 

補助目盛も、十分なスペースがない場合は表示されません。 

同様に、Max log cycles with minor tick labels 設定を使って、いつ Igor が対数軸の補助目盛にラベルを付けるか

をコントロールできます。 

これは 0 から 8 までの数字です。 

0 は補助目盛ラベルを無効にします。 

軸がこの設定より少ない decade を持つ限り、補助目盛にラベルが付けられます。 
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日付/時刻軸 

 

数値軸に加えて、Igor は日付、時刻、日付と時刻でラベリングされた軸をサポートしています。 

Igor では、日付と日付/時刻を 1904 年 1 月 1 日午前 0 時からの経過秒数で表します。 

Igor では、日付は単精度ウェーブでは正確に表現できません。 

日付と日付/時刻を保存するときは、必ず倍精度ウェーブを使ってください。 

（単精度ウェーブは、その X スケーリングから計算された日付と日付/時刻を提供できますが、データ値からは提供

できません） 

Igor による日付の表現方法の詳細については、マニュアル II-85 Date/Time Waves を参照してください。 

日付のない時刻は、２つの方法で考えることができます：１つはその日の時刻として、もう１つは経過時間としてで

す。 

Igor では、時刻は午前 0 時からの経過秒数で表されます。 

経過時間は、-9999:50:50 から +9999:59:59 の範囲の秒数で表示されます。 

秒単位の整数については、この経過時間の範囲は符号付き 32 ビットの整数ウェーブで正確に表現できます。 

単精度浮動小数点ウェーブは、約 +/-4600 時間までの整数秒の経過時間を正確に表現できます。 

 

1．軸をコントロールするウェーブの適切な単位が「dat」の場合、

Igor は軸上に日付または時刻を表示します。 

これは大文字と小文字が区別されます。「Dat」では動作しませ

ん。 

ウェーブの単位は、Data メニューの Change Wave Scaling を

使うか、コマンドウィンドウで SetScale コマンドを使って設定で

きます。 
 

2．Change Wave Scaling ダイアログの Units Type で、

Date/Time を設定すると、Units が自動的に「dat」に変わりま

す。 

水平軸をウェーブフォームグラフの日付または時刻軸にするには、

軸をコントロールするウェーブの X 単位を「dat」に設定する必要

があります。 

XY グラフの場合、カーブの X 座標を供給するウェーブのデータ単

位を「dat」に設定する必要があります。 

縦軸をいずれかの種類のグラフの日付軸または時刻軸にするには、

軸をコントロールするウェーブのデータ単位を「dat」にする必要が

あります。 

 

 

 

 

 

 

 

 

 

3．Modify Axis ダイアログの Axis タブで軸モードとして 

Date/Time を選択すると、ダイアログは適切なウェーブの単位を

「dat」に設定します。 
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Igor で軸を日付または時刻として表示するには、次の追加の制限を

満たす必要があります：軸は少なくとも、２秒間の幅を持つ必要が

あり、両端は Date/Time 値の許容範囲内に収まる必要がありま

す。 

これらの制限のいずれかが満たされない場合、Igor は１つの目盛の

みを表示します。 

 

4．軸が Date/Time モードの場合、Modify Axis ダイアログの 

Ticks and Grids タブにある Date/Time Tick Labels チェック

ボックスが使えるようになります。 

 

5．Time Format ポップアップメニューから、Normal、

Military、Elapsed を選択できます。 

時刻を表す場合は Normal または Military を、時間経過を表す場

合は Elapsed を使います。 

Normal モードでは、午前 0 時の１分前は 11:59:00 PM と表示

され、午前 0 時は 12:00:00 AM と表示されます。 

Military モードの場合は、それぞれ 23:59:00 と 00:00:00 と表

示されます。 

Elapsed モードでは、-9999:59:59 から +9999:59:59 までの

時間を表示できます。 

このモードは、軸に表示される値が実際に経過時間（例：

23:59:00）であるときに意味があります。 

値が実際には Date/Time（例：7/28/93 23:59:00）である場合に

は意味がなく、目盛ラベルも表示されません。 
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カスタムの日付フォーマット 

1．Date Format ポップアップメニューから、Short、Long、

Abbrev（Abbreviated）、Other を選択できます。 

Short、Long、Abbrev の各モードでは、日付はシステムの 

Date/Time 設定に従って表示されます。 

Date Format ポップアップメニューで Other を選択すると、目

盛ラベルのフォーマットをほぼ完全にコントロールできるダイアロ

グが表示されます。 

 

 

 

 

 

 

 

2．ダイアログでは、さまざまな組み込みフォーマットから選択し

たり、完全にカスタム化したフォーマットを作成したりすることが

できます。 

 

3．軸の範囲に応じて、目盛ラベルには日付と時刻が表示される場

合があります。 

日時の表示の時に日付の表示を抑制するには、Suppress Date 

を選択します。 

経過時間モードを選択していて、日付が表示されない場合は、この

メニューは無関係です。 

 

 

 

 

 

 

 

4．次の例では、温度を Y 値とし、SetScale コマンドで設定した X 値を日付とするウェーブフォームの 

Date/Time グラフを作成する方法を示しています。（コメントの入力は任意です） 

// １年間の気温を含むウェーブを作成（華氏） 

Make /N=365 temperature               // 単精度データ値 

// スケーリングを設定して、X 値を日付にする 

Variable t0, t1 

t0 = Date2Secs(2000,1,1); t1 = Date2Secs(2001,1,1) 

SetScale x t0, t1, "dat", temperature    // 倍精度 X スケーリング 

// 気温データをウェーブの Y 値に入力 

t0 = Date2Secs(2000,1,1); t1 = Date2Secs(2000,3,31)    // 冬 

temperature(t0, t1) = 32                          // 寒い 

t0 = Date2Secs(2000,4,1); t1 = Date2Secs(2000,6,30)    // 春 

temperature(t0, t1) = 65                          // ちょうどよい 

t0 = Date2Secs(2000,7,1); t1 = Date2Secs(2000,9,31)    // 夏 

temperature(t0, t1) = 85                          // 暑い 

t0 = Date2Secs(2000,10,1); t1 = Date2Secs(2000,12,31)  // 秋 

temperature(t0, t1) = 45                          // 寒くなってきた 
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// データを平準化 

CurveFit sin temperature 

temperature= K0+K1*sin(K2*x+K3) 

// ウェーブのグラフを表示 

Display temperature 

SetAxis left, 0, 100;Label left "temp" 

Label bottom "2000" 

実行結果は次のようになります。 

 

SetScale コマンドは、X 値が 2000 年全体にわたるように気温のウェーブを設定します。 

この例では、Date/Time の情報はウェーブの X 値に含まれています。 

X 値は常に倍精度です。 

Y 値には Date/Time 情報ではなく気温情報を格納しているため、ウェーブ自体は倍精度と宣言されていません。 

 

Date/Time 軸に対する手動の目盛 

通常の軸の場合と同様に、Igor が Date/Time 軸の目盛を自動的に選択した結果が、希望するものではないとしま

す。 

このようなときには、Date/Time 軸に計算された手動の目盛を使うことができます。 

 

1．計算された手動の目盛を使うには、軸をダブルクリックする

か、メニュー Graph → Modify Axis を選択して、Modify 

Axis ダイアログを表示します。 

Auto/Man Ticks タブを選択し、そのタブのメニューから 

Computed Manual Ticks を選択します。 
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2．Set to auto values ボタンをクリックします。 

Canonic Tick 設定の下にあるポップアップメニューから、

Date、Time、Date&Time のいずれかを選択します。 

これはデータの範囲によって異なります。 

Tick Increment 設定の単位を選択し、インクリメント値を入力

します。 
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フェイク軸 

 

単純にデータを関連付けない軸を作る必要が生じることがあります。 

その１つの方法は、ウェーブに関連付けられていない自由軸を使う方法です（NewFreeAxis コマンドを参照）。 

Transform Axis パッケージは、このテクニックを使って、データの異なるビューを反映する鏡像軸を作成します。 

 

1．例えば、ウェーブ長を示す主軸に合わせるウェーブ数を示す鏡

像軸などです。 

例としては、メニュー File → Example Experiments → 

Graphing Techniques → Tranform Axis Demo がありま

す。 

 

2．別のテクニックとして、Igor の描画ツールを使ってフェイク

軸を作る方法があります。 

例としては、メニュー 

File → Example Experiments → Graphing Techniques → 

New Polar Graph Demo 

または 

File → Example Experiments → Graphing Techniques → 

Ternary Diagram Demo 

があります。 
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軸ラベル 

 

グラフの軸ラベルのテキストは、２つの場所のうちの１つから使うことができます。 

軸をコントロールするウェーブの単位を Change Wave Scaling ダイアログで指定すると、Igor はこれらの単位を

使って軸にラベル付けを行います。 

Modify Axis ダイアログの Axis Label タブを使って軸ラベルテキストを明示的に入力することで、このラベル表示

を上書きすることができます。 

 

1．メニュー Graph → Label Axis を選択するか、軸ラベルを

ダブルクリックします。 

Axis ポップアップメニューからラベル付けをする軸を選択し、

Axis Label 領域に軸ラベルのテキストを入力します。 

ラベルのフォーマットに関するその他のオプションは、Label 

Options タブで設定できます。 

 

2．軸ラベルには２つの部分があります。ラベルのテキスト、フォント・フォントサイズ・上付き/下付き文字など

の特殊効果です。 

Axis Label 領域にテキスト入力して指定します。 

テキストを入力するどの時点でも、左の Insert セクションのポップアップメニューから特殊効果を選択すること

ができます。 

Label Preview 領域では、テキストと特殊効果を考慮した軸ラベルの表示例が示されます。 

プレビューにはテキストを入力できません。 

Live Update チェックボックスにチェックを入れると、グラフ上にラベルがリアルタイムに更新されます。 

 

軸ラベルでのエスケープコード 

1．特殊効果を選択すると、Igor がテキストにエスケープコード

を挿入します。 

エスケープコードは、バックスラッシュ文字に１文字または複数文

字が続く形式です。 

これは、あなたが選択した特殊効果を表しています。 

エスケープコードは解りにくいですが、その効果は Label 

Preview 領域で確認できます。 

 

 

 

 

 

2．テキストの任意の個所をクリックし、Insert ポップアップメニューから特殊効果を選択することで、テキスト

の任意の個所に特殊効果を挿入できます。 
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3．Font ポップアップメニューから項目を選択すると、ラベル内

の後続の文字のフォントを変更するコードが挿入されます。 

Font ポップアップメニューには、Recall font という項目もあり

ます。 

この項目は、凝った軸ラベルを作るために使います。 

マニュアル III-51 Elaborate Annotations を参照してください。 

 

 

 

 

 

 

 

4．Font Size ポップアップメニューから項目を選択すると、ラベ

ル内の後続の文字のフォントサイズを変更するコードが挿入されま

す。 

Font Size ポップアップメニューには、Recall font という項目が

あり、凝った軸ラベルを作るために使います。 

 

 

軸ラベルでの特殊効果 

Special ポップアップメニューメニューには、Superscript（上付

き文字）、Subscript（下付き文字）、Justification（文字そろ

え）、Text Color（文字色）などの多くの機能のコントロールに加

え、特殊文字、マーカー、画像の挿入の項目が含まれています。 

Store Info、Recall Info、Recall X Position、Recall Y Position 

の各項目は、詳細な注釈を作るために使います。 

マニュアル III-51 Elaborate Annotations を参照してください。 
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最もよく使うのは、Superscript、Subscript、Normal です。 

上付き文字や下付き文字を作るには、Special ポップアップメニューを使って必要なコードを挿入し、上付き文字ま

たは下付き文字のテキストを入力し、最後に通常に戻す Normal コードを入れて終了します。 

例えば、Phase space density (s3m-6) と表示される軸ラベルを作りたいとします。 

これを行うには、 

1. "Phase space density (s" と入力 

2. Special ポップアップメニューから Superscript を選択 

3. "3" と入力 

4. Special ポップアップメニューから Normal を選択 

5. "m" と入力 

6. Special ポップアップメニューから Superscript を選択 

7. "-6" と入力 

8. Special ポップアップメニューから Normal を選択 

9. ")" と入力 

これらの項目に関する詳細な説明は、マニュアル III-2 Annotations を参照してください。 

 

Wave Controlling Axis 項目は、指定された軸にプロットされた最初のウェーブの名前を表示するコードを挿

入します。 

Trace Symbol サブメニューは、選択したトレースのプロットに使うシンボルを描画するコードを挿入しま

す。 

Marker サブメニューは、マーカーシンボルを描画するコードを挿入します。 

これらのシンボルは、グラフ内のトレースとは独立しています。 

Character メニューは、軸ラベルに追加する特殊文字を選択できるパレットを表示します。 

 

軸ラベルの単位 

Units ポップアップメニューの項目は、軸の範囲が変更されたとき

に、自動的に変更される軸ラベルを作るためのエスケープコードを

挿入します。  
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軸のコントロールウェーブの単位を指定した場合、Units ポップアップメニューから Units を選択することで、軸

ラベルにそれらの単位を表示することができます。 

適切な場合、Igor は自動的にラベルに接頭語（マイクロの場合は μ、ミリの場合は m など）を追加し、軸の範囲

が変更された場合は、接頭語を適切に変更します。 

軸を明示的に設定したり、自動スケーリングを行うと、軸の範囲が変化します。 

Units ポップアップメニューから Scaling または Inverse Scaling を選択すると、Igor は軸ラベルに 10 のべき

乗（x10^3、x10^6 など）のスケールを自動的に追加し、軸の範囲が変更された場合はこのスケールを変更します。 

Trial Exponent ラジオボタンは、ラベルプレビューだけで使用する

べき指数を決定します。 

これにより、軸のスケーリング条件が異なる場合のラベルの見え方

を確認することができます。 

この設定はどちらも曖昧である可能性があります。 

軸がスケールファクターで乗算されたのか、あるいは単位がスケー

ルファクターを含んでいるかが明確ではありません。 

より曖昧性の少ない方法は Exponential Prefix エスケープコード

を使うことです。 

これは「x」がないことを除いて、スケーリングのエスケープコード

と同じです。 

この場合は、単位の倍数であることが明確な状況で使うことができ

ます。 

例えば、軸の範囲が 0 から 3E9（単位 cm/s）の場合、「Speed, 

\ucm/s」と入力すると「Speed, 109cm/s」が作成されます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

軸ラベルのスケーリング情報を括弧で囲むことは一般的です。 

例えば、ラベルに「Joules (x106)」と記載されている場合です。 

これは、Scaling または Inverse Scaling エスケープコードを括弧で囲むだけで実行できます。 

軸のスケーリングが x100 であることが判明した場合、Igor はそれを省略して、括弧も省略するので、「Joules 

(x100)」や「Joules ()」ではなく、「Joules」となります。 

スケーリングを指定しない場合でも、軸の範囲がそれを必要とする場合は、Igor は目盛ラベルの１つに軸のスケー

リングラベルを付けます。 

これは、グラフが誤解を招くことを防ぐための緊急措置です。 

ラベルに Manual Override エスケープコード「\u#2」を挿入することでこの問題を回避できます。 

エスケープコードの位置や目盛は、スケーリングや単位の情報は追加されません。 

対数軸の場合は少し異なります。 

本来、対数軸はスケーリングする必要がなく、軸ラベルでは単位/スケーリングのエスケープコードは使われませ

ん。 

対数軸のコントロールウェーブに単位がある場合、Igor は自動的に各主目盛ラベルに適切なプリフィックスととも

に単位を使います。 
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グラフ内のアノテーション 

 

1．グラフにテキストアノテーションを追加するには、メニュー 

Graph → Add Annotation を選択します。 

 

2．これにより、Add Annotation ダイアログが表示されます。 

 

3．グラフ上にテキストアノテーションが既に表示されている場合

は、それをダブルクリックすることで変更できます。 

これにより、Modify Annotation ダイアログが表示されます。 

詳細は、マニュアル III-2 Annotations を参照してください。 
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情報パネルとカーソル 

 

1．メニュー Graph → Show Info を選択して情報パネルを表

示できます。 

 

2．情報パネルには、グラフのウェーブの正確な数値が表示されま

す。 

グラフがアクティブなウィンドウである場合に、グラフから情報パ

ネルを削除するには、メニュー Graph → Hide Info を選択し

ます。 

 

3．AB から IJ まで５つの異なるカーソルペアを使用できます。 

使用可能なカーソルペアをコントロールするには、情報パネルの歯

車アイコンをクリックし、Show Cursor Pairs サブメニューか

らカーソルペアを選択します。 

デフォルトでは、B 以降のカーソルは十字と文字スタイルを使い

ます。 

 

カーソルは、特に注目したいウェーブ上のポイントの範囲を指定する便利な方法です。 

例えば、ウェーブ上の特定の点の範囲にカーブフィッティングを行いたい場合、まず、範囲の一方の端にカーソル 

A を、もう一方の端にカーソル B を置きます。 

4．次に、Analysis メニューから Curve Fitting ダイアログを

呼び出します。 

このダイアログの Data Options タブには、範囲コントロールが

あります。 

Cursors ボタンをクリックすると、フィッティングの範囲が 

Cursor A から Cursor B までの範囲に設定されます。 
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カーソルの使用 

1．最初に情報パネルを表示すると、カーソルはホームにあり、ど

のウェーブにも関連付けられていません。 

スライドコントロールは無効になっており、読み取り領域には値が

表示されていません。 

 

 

2．カーソルをアクティブにするには、それをクリックし、値を調

べたいウェーブ上の点までドラッグします。 

カーソルがグラフ上に表示され、カーソルのホームアイコンが黒色

に変わり、カーソルがアクティブになったことを示します。 

カーソルが置かれているウェーブの名前が、カーソルの名前の隣に

表示されます。 

カーソルをトレースまたは画像プロットの任意の点にドラッグする

ことができます。 

 

カーソルを１要素分移動するには、キーボードの矢印キーを使います。 

カーソルがトレース上にある場合は、左矢印キーと右矢印キーを使うことができます。 

カーソルが画像上にある場合は、左矢印キー、右矢印キー、上矢印キー、下矢印キーを使うことができます。 

Shift キーと矢印キーを同時に押すと、カーソルが 10 倍の距離だけ移動します。 

カーソルがトレース上にある場合、スライドコントロールを左右にドラッグできます。 

画像上にある場合は、任意の方向にドラッグできます。 

グラフ上にペアとなる両方のカーソルがあり、両方がアクティブになっている場合、スライドコントロールは両方

のカーソルを同時に移動させます。 

片方のカーソルだけを移動させたい場合は、マウスでそのカーソルを新しい位置までドラッグすることができます。 

カーソルを１つだけ移動させる別の方法としては、移動させたくないほうのカーソルを非アクティブにします。 

これはカーソルのホームアイコン（アクティブなときには黒くなっています）をクリックすることで行います。 

これにより、ホームアイコンが黒から白に変わり、カーソルがアクティブではなくなったことを示します。 

そうすると、スライドコントロールはアクティブなカーソルだけを移動させます。 

また、ペアになっている両方のカーソルを同時にドラッグして移動することもできます。 

グラフ上に両方のカーソルがある状態で、Shift キーを押しながらいずれかのカーソルをクリックしてドラッグしま

す。 

マウスを使ってカーソルを新しい位置にドラッグすると、Igor はまず、現在カーソルが接続されているトレースを

検索します。 

新しい場所が、現在のトレース上の点から離れている場合のみ、他のすべてのトレースが検索されます。 

この現在のトレースの優先処理を使うと、目的の領域で多くのトレースが重なっている場合でも、カーソルを目的

のトレース上に確実に配置することができます。 
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3．カーソルのホームアイコンを右クリックし、ポップアップメニ

ューからトレース名を選択することで、特定のトレースにカーソル

を関連付けることができます。 

 

4．グラフからカーソルを削除するには、プロット領域の外までドラッグするか、カーソルのホームアイコン

を右クリックして、Remove Cursor を選択します。 

 

フリーカーソル 

デフォルトでは、カーソルはトレース上の特定のポイント、または画像プロットの特定の要素に割り当てられます。 

これに対して、グラフのプロット領域内であれば、フリーカーソルをどこにでも移動させることができます。 

 

カーソルをフリーにするには、情報パネル内のカーソルのホームア

イコンを右クリックし、は表示されるポップアップメニューから 

Style → Free を選択します。 

 

 

カーソルスタイル 

デフォルトでは、Cursor A には円形のアイコン、Cursor B には四角形のアイコンが使われてグラフに表示されま

す。 

その他のすべてのカーソルについては、デフォルトのスタイルは十字です。 

 

1．カーソルのスタイルは、情報パネル内のカーソルのホームアイ

コンを右クリックして表示されるポップアップメニューを使って、

任意のカーソルに変更することができます。 
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2．指定されたカーソルスタイル設定を後から呼び出して適用でき

るカーソルスタイル機能を作ることができます。 

情報パネル内のカーソルのホームアイコンを右クリックし、Style 

→ Style Function → Save Style Function を選択します。 

 

3．Igor は、ビルトインプロシージャウィンドウ（メニュー 

Windows → Procedure Windows）にカーソルスタイル関数を作

成します。 

Igor が生成したデフォルト名よりも意味のある名前を付けるため

に、関数を編集することができます。 
 

4．カーソルにスタイル機能を適用するには、情報パネルのカーソ

ルのホームアイコンを右クリックして、Style → Style 

Function → <独自のスタイル機能> を選択します。 

 

 

カーソルに対するプログラミング 

以下で説明する機能とコマンドは、カーソルに対するプログラミングに役立ちます。 

ShowInfo と HideInfo コマンドは、情報パネルの表示と非表示を切り替えます。 

Cursor コマンドは、カーソルの位置を設定します。 

また、色、ヘアースタイル、Graph Info Panel 表示に使われる桁数などのカーソルの特性を変更することもできま

す。 

CsrInfo コマンドは、カーソルに関する情報を返します。 

次のコマンドは、カーソルの現在の位置を返します。 

pcsr qcsr hcsr vcsr xcsr zcsr 

実行例： 
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実行例： 

 

次のコマンドは、カーソルが添付されているウェーブに関する情報を返します。 

CsrWave CsrWaveRef CsrXWave CsrYWaveRef 

実行例： 

 

CursorStyle キーワードは、カーソルポップアップメニューの Style Function サブメニューに含めるためのユー

ザー定義関数をマークします。 

マニュアル IV-339 Cursors - Moving Cursor Calls Function では、カーソルが移動されるときにユーザー定義関

数をトリガーする方法を説明しています。 
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トレースの特定 

 

Igor は、マウスをトレースの上に置いたときにトレースを識別するツールチップを表示することができます。 

 

このモードを有効にするには、Graph → Show Trace Info 

Tags を選択します。 
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サブレンジ（範囲の一部）の表示 

 

グラフにウェーブ全体を表示するだけでなく、ウェーブのサブレンジ（一部）を表示することもできます。 

この機能は、行列をあたかも個別の 1D ウェーブに抽出したかのように表示することを主目的としていますが、他

のサブセットの表示や、n 番目ごとのデータ点をスキップするのにも使うことができます。 

 

New Graph ダイアログ、および Append Traces ダイアログを

使ってグラフのサブレンジを表示するには、More Choices ボタン

をクリックして表示される、より複雑なバージョンのダイアログを

使う必要があります。 

Y ウェーブを選択し、オプションで X ウェーブを選択して、Add 

ボタンをクリックします。 

これにより、トレースが下のリストに追加されます。 

次に、リスト内のサブレンジを編集することができます。 

 

 

 

 

 

 

 

 

 

 

サブレンジの表示のシンタックス 

Display コマンド（マニュアル V-161）、AppendToGraph コマンド（マニュアル V-35）、ReplaceWave コマ

ンド（マニュアル V-801）では、ウェーブリスト項目として以下のサブレンジ構文がサポートされています。 

wavename [rdspec] [rdspec] [rdspec] [rdspec]  

rdspec は、次元インデックス（1D ウェーブの点の番号）として表される範囲または次元の指定です。 

n 次元ウェーブの場合は、n 個の指定子を入力し、残りは省略します。 

範囲指定子は１つだけです。 

他の要素は、単一の数値要素インデックスまたは次元ラベル値でなければなりません。 

次元の全範囲を示すには、[] または [*] を入力します。 

連続したサブレンジを示すには [start,stop] を入力します。 

start、stop、inc が次元インデックスである場合は、[start,stop;inc] と入力します。 

stop に * を入れると、次元の最後の要素のインデックスを入れたことと同じです。 

例えば、 

Make/N=100 w1D = p 

Display w1D[0,*;10]                  // 10 番目の点ごとに表示 

ModifyGraph mode=3, marker=19 

Make/N=(10,8) w2D = p + 10*q 

Display w2D[0][0,*;2]                // 行 0 の偶数番目の列を表示 

ModifyGraph mode=3, marker=19 

サブレンジの構文規則は、次のように言い直すことができます。 

1. 表示する範囲を含めることができるのは１つのディメンション指定子だけです。 

範囲を表す正しい構文は： 

◆ ディメンション全体は、[] または [*] 
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◆ サブレンジは、[start,stop] 

◆ stop は * にもできる 

◆ stop は start 以上の値 

◆ 範囲は両端を含む 

◆ 正のインクリメントを持つサブレンジは、[start,stop;inc] 

2. その他のディメンションには、% 構文を使った単一の数値インデックスまたはディメンションラベルを含める必

要があります。 

◆ 範囲ではない正しい構文： [index] 

◆ 指定子： [%label] 

3. 未指定の高次元は [0] が指定されたものとして扱われます。 

XY プロット以外のプロットでは、X 軸ラベルはアクティブなディメンション（レンジを持つもの）のディメンショ

ンラベル（ある場合）を使います。 

カーソルまたはタグがサブレンジのトレース上に置かれた場合、使われるポイントの番号は、サブレンジが 1D ウ

ェーブとして抽出されたかのような仮想の点の番号となります。 

サブレンジの構文は、エラーバーを持つウェーブ、または色、マーカーサイズ、f(z) としてマーカー番号を持つウェ

ーブもサポートしています。 

これらは、ウェーブキーワードを持つ ErrorBars コマンド（マニュアル V-199）、zmrkSize, zmrkNum, zColor 

キーワードを持つ ModifyGraph (traces) コマンド（マニュアル V-613）に対応しています。 

 

サブレンジの表示の制限 

カテゴリプロットでは、カテゴリウェーブ（テキストウエーブ）がサブレンジにできない場合があります。 

ModifyGraph textMarker モードを使ってテキストを指定するときに、ウェーブがサブレンジにできない場合があり

ます。 

サブレンジのトレースは、描画ツール（例えば、グラフ上のツールパレットの編集ポリゴンアイコンをオプションク

リック）を使って編集できない場合があります。 

ウォーターフォールプロットでは、サブレンジを使わないかもしれません。 

同じウェーブの複数のサブレンジが使われる場合、それらはインスタンス表記のみを使って区別され、サブレンジの

構文は使いません。 

例えば、display w[][0],w[][1] に対しては、ModifyGraph mode(w[][0])=1,mode(w[][1])=2 ではな

く、ModifyGraph mode(w#0)=1,mode(w#2)=2 を使う必要があります。 

トレース情報には、指定のトレースをプロットするために使われたトレースインスタンスとサブレンジが含まれてい

ます。 

マニュアル II-321 Identifying a Trace を参照してください。 
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グラフの印刷 

 

1．グラフを印刷する前に、Page Setup ダイアログを使ってペ

ージサイズと方向を設定してください。 

File メニューから Page Setup を選択します。 

グラフは縦よりも横に長い場合が多く、横方向で印刷すると見栄え

が良くなります。 

Page Setup ダイアログを呼び出すときは、印刷したいグラフが最

前面にあることを確認してください。 

Igor は、すべてのグラフについて、各 Experiment 内に１ページ

のセットアップを保存し、他の種類のウィンドウについては他のペ

ージセットアップを保存します。 

 

 

 

 

 

 

 

 

 

 

2．新しい Experiment に対するデフォルトのグラフページ設定

は、Capture Graph Preferences ダイアログを使って設定できま

す。 

 

 

グラフを印刷するには、グラフウィンドウをアクティブにして File → Print を選択します。 

また、File → Print Preview を選択して、プレビューを表示することもできます。 

グラフは、グラフウィンドウに収まらない場合を除き、デフォルトではグラフウィンドウと同じサイズで印刷されま

す。 

収まらない場合は、同じ縦横比で縮小されます。 

Igor Pro 7 以前では、Print ダイアログは Fill Page と Same Aspect のような拡大縮小モードがサポートされて

いました。 

これらのモードは、Print ダイアログでは使用できなくなりました。 

印刷前に、graphMode と graphSize のキーワードとともに PrintSettings を使うことで、同様の結果を得るこ

とができます。 

コマンドウィンドウで 

PrintSettings graphSize={30,30,300,200} 

のように入力し、File → Print Window Preview で出力の変化を確認することができます。 

 

ポスターサイズのグラフの印刷 

PrintGraphs コマンドを使うと、１枚の用紙には大きすぎるグラフのサイズを指定することができます。 

このコマンドを使うと、Igor は複数の用紙を使ってグラフを印刷します。 
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複数のシートを１枚の大きなポスターにするには、シートの端を切り落とし、テープで張り合わせる必要がありま

す。 

Igor はページをそろえるための小さな位置合わせマークを端に印刷します。 

不要な余白を切り落とし、位置合わせマークが切り取られたシートの端に揃うようにします。 

次に、シートを揃えて、位置合わせマークが互いに一致するようにします。 

位置合わせマークはすべてまだ見えるはずです。 

最後に、シートをテープで張り合わせます。 

 

その他の印刷方法 

ページレイアウトに配置して、グラフを印刷することができます。 

詳細は、マニュアル II-18 Page Layouts を参照してください。 

PrintGraphs コマンド（マニュアル V-773 を参照）を使って、マクロから直接グラフを印刷することができます。 
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グラフのコピーを保存 

 

1．アクティブなグラフを Igor パック形式の Experiment と

して保存するには、File → Save Graph Copy を選択します。 

パック形式の Experiment として保存する主な用途は、データの

アーカイブコピーを保存したり、複数の Experiment からデータ

をマージする準備をすることです（マニュアル II-19 Merging 

Experiments を参照）。 
 

2．生成された Experiment ファイルは、グラフに表示されてい

るウェーブのデータフォルダー階層を「トップ」データフォルダー

から保存します。 

トップデータフォルダーとは、グラフに表示されているすべてのウ

ェーブを囲んでいるデータフォルダーです。 

トップのデータフォルダーが、生成された Experiment ファイル

の root データフォルダーになります。 

圧縮された Experiment ファイルには、グラフ、そのウェーブ、

破線設定、グラフで使っている画像のみが保存され、プロシージ

ャ、変数、文字列、その他のオブジェクトは保存されません。 

下の画面の右側が Save Graph Copy で保存した Experiment 

を開いたものです（左側は元の Experiment）。 

 

 

 

 

 

 

 

 

 

 

 

 

コントロールを含むグラフでは、Save Graph Copy が適切に動作しない場合があります。 

まず、コントロールはウェーブ、変数、または FIFO（チャートコントロール用）に依存している可能性があり、こ

れらは Save Graph Copy 機能では保存されません。 

次に、コントロールは通常、Save Graph Copy では保存されないプロシージャに依存しています。 

別のウェーブ、グラフに表示されていない wave1 について、Save Graph Copy は wave0 は保存しますが、

wave1 は保存しません。 

保存した Experiment を開くと、依存関係が途切れます。 

マニュアル V-821 の SaveGraphCopy コマンドでは、Save Graph Copy メニューでは使うことができないオプ

ションが提供されています。 
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グラフのエクスポート 

 

グラフをクリップボード経由、またはファイル作成により、他のア

プリケーションにエクスポートすることができます。 

クリップボード経由でエクスポートするには、Edit → Export 

Graphics を選択します。 

ファイル経由でエクスポートするには、File → Save Graphics 

を選択します。 

 

 

グラフからグラフィックスをエクスポートするプロセスは、レイアウトからグラフィックスをエクスポートするプロ

セスと非常に似ています。 

そのため、詳細はマニュアル III-6 Exporting Graphics に記載しています。 

そこでは、使うことができるさまざまなエクスポート方法と、最良の結果を得るための方法について説明していま

す。 
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